Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 121031

Summary: lm_sensors ... causes a memory leak
Product: Gentoo Linux Reporter: Daniel <deepee>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: 2005.1   
Hardware: All   
OS: Other   
Whiteboard:
Package list:
Runtime testing required: ---

Description Daniel 2006-01-31 03:35:12 UTC
emerging net-snmp worked fine but the following information was completely new to me:

>>> original instance of package unmerged safely.
 * lm_sensors support is no longer available because it
 * causes a memory leak.

Asking/browsing bugzilla (for memory leak regarding lm_sensors and/or net-snmp) don't returned any usefull further informations? Have I missed something? If not I would have the following suggestion:

In my opinion a bug that is already known (see above) should at least be documented/assigned to the according party. After assignment the above ebuild-output should be extended with the bug# to make it easier to find further details. This also allows anoybody interessted in this topic to follow the development/bugfix work.

Thanks a lot!



emerge --info output (if anybody needs it?!)
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.14-gentoo-r5 i686)
=================================================================
System uname: 2.6.14-gentoo-r5 i686 Pentium III (Coppermine)
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/fax /usr/share/config /var/bind /var/qmail/control /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/gentoo-de"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib acpi alsa apache2 apm arts audiofile avi bash-completion bcmath berkdb bitmap-fonts bzip2 bzlib cdb cdparanoia cdr cpdflib crypt ctype cups curl curlwrappers dedicated directfb dvd dvdr eds emboss encode ethereal exif expat fam fbcon flash foomaticdb fortran freetype ftp gd geoip gif gmp gpm gps gstreamer gtk2 iconv icq idn ieee1394 imagemagick imlib ipv6 jabber java javascript jpeg kde ldap libg++ libwww lirc lm_sensors mad mcal mhash mikmod milter mime ming mng motif mp3 mpeg mysql ncurses nls offensive ogg oggvorbis opengl oss pam pcntl pcre pdflib perl php png posix python qt quicktime readline recode ruby samba sasl sdl sharedext slang slp snmp sockets socks5 spell ssl svg svgalib symlink tcltk tcpd threads tidy tiff truetype truetype-fonts type1-fonts udev unicode usb vhosts vorbis wmf xml xml2 xmlrpc xmms xpm xsl xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-31 03:37:46 UTC
(In reply to comment #0)
> In my opinion a bug that is already known (see above) should at least be
> documented/assigned to the according party.

Sure, why just you don't read the changelog?

  23 Jan 2006; Marcelo Goes <vanquirius@gentoo.org>
  net-snmp-5.2.1.2-r1.ebuild, net-snmp-5.2.2-r1.ebuild,
  net-snmp-5.3_rc2.ebuild:
  Commented lm_sensors patch because it has a memory leak. Please see bug
  109785. If you can fix this problem, please attach a patch.



*** This bug has been marked as a duplicate of 109785 ***