Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 117595

Summary: PEAR-PEAR-1.3.6-r1 fails with "Could not startup"
Product: Gentoo Linux Reporter: Mervin <garmoan>
Component: New packagesAssignee: PHP Bugs <php-bugs>
Severity: normal CC: dldudley
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Mervin 2006-01-03 06:22:56 UTC
As i try to update PEAR, this occurs:

Calculating world dependencies  ...done!
>>> emerge (1 of 53) dev-php/PEAR-PEAR-1.3.6-r1 to /
>>> checksums files   ;-) PEAR-PEAR-1.3.6-r1.ebuild
>>> checksums files   ;-) PEAR-PEAR-1.3.5.ebuild
>>> checksums files   ;-) PEAR-PEAR-1.3.5-r1.ebuild
>>> checksums files   ;-) files/digest-PEAR-PEAR-1.3.6-r1
>>> checksums files   ;-) files/digest-PEAR-PEAR-1.3.5-r1
>>> checksums files   ;-) files/digest-PEAR-PEAR-1.3.5
>>> checksums src_uri ;-) Archive_Tar-1.3.1.tgz
>>> checksums src_uri ;-) Console_Getopt-1.2.tgz
>>> checksums src_uri ;-) XML_RPC-1.4.3.tgz
>>> checksums src_uri ;-) PEAR-1.3.6.tgz
 * Using dev-lang/php-4.4.1-r2
 * Checking for required PHP feature(s):
>>> Unpacking source...
>>> Unpacking Archive_Tar-1.3.1.tgz to /var/tmp/portage/PEAR-PEAR-1.3.6-r1/work
tar: A lone zero block at 168
>>> Unpacking Console_Getopt-1.2.tgz to /var/tmp/portage/PEAR-PEAR-1.3.6-r1/work
tar: A lone zero block at 27
>>> Unpacking XML_RPC-1.4.3.tgz to /var/tmp/portage/PEAR-PEAR-1.3.6-r1/work
tar: A lone zero block at 256
>>> Unpacking PEAR-1.3.6.tgz to /var/tmp/portage/PEAR-PEAR-1.3.6-r1/work
tar: A lone zero block at 1089
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/PEAR-PEAR-1.3.6-r1 ...
>>> Source compiled.
>>> Test phase [not enabled]: dev-php/PEAR-PEAR-1.3.6-r1

>>> Install PEAR-PEAR-1.3.6-r1 into /var/tmp/portage/PEAR-PEAR-1.3.6-r1/image/ category dev-php
>>> dobin: making pear executable...
Could not startup.

!!! ERROR: dev-php/PEAR-PEAR-1.3.6-r1 failed.
!!! Function install_pear_after_bootstrap, Line 108, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

This should be a new bug, searching here and google has yielded no relevant answers. thanks for any help/solutions!
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-03 06:37:49 UTC
emerge --info, please.
Comment 2 Mervin 2006-01-03 06:47:02 UTC
(In reply to comment #1)
> emerge --info, please.

Portage 2.1_pre3-r1 (default-linux/x86/2005.1, gcc-3.3.3, glibc-2.3.5-r3, 2.6.12-gentoo-r2 i686)
System uname: 2.6.12-gentoo-r2 i686 Pentium III (Coppermine)
Gentoo Base System version 1.12.0_pre12
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.2.3-r5, 2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
CFLAGS="-march=pentium3 -O3 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O3 -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
USE="x86 X aalib alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bonobo bzip2 cdr cli crypt cups curl dba debug dvd dvdr eds emboss encode esd ethereal exif expat fam ffmpeg flac foomaticdb fortran ftp gd gd-external gdbm geoip gif glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml idn imagemagick imlib ipv6 java jpeg junit kde lcms libcaca libg++ libwww lua mad memlimit mhash mikmod mng motif mozilla mp3 mpeg mysql ncurses nls offensive ogg oggvorbis openal opengl oss pam pcre pdflib pear perl php png posix ppds python qt quicktime readline recode samba sdl session slang sockets spell ssl svga tcpd tidy tiff tokenizer transcode truetype truetype-fonts type1-fonts udev usb vorbis xine xinerama xml xml2 xmms xv xvid zlib elibc_glibc kernel_linux userland_GNU"
Comment 3 Luca Longinotti (RETIRED) gentoo-dev 2006-01-03 08:43:42 UTC
Please also post emerge -pv =dev-lang/php-4* and /usr/lib/php4/bin/php -v, thanks.
Best regards, CHTEKK.
Comment 4 David Dudley 2006-01-03 13:17:31 UTC
I'm going to have to agree that I have this bug also.
I have so far tried removing all PHP support and then re-emerging it, rebuilding as many packages as I can to recover the program, modifying the .ini file in various degrees, running revdep-rebuild at various states, etc. .... no success.

emerge -pv =dev-lang/php-4* gives this:
[ebuild   R   ] dev-lang/php-4.4.1-r2  -adabas -apache +apache2 +bcmath +berkdb -birdstep +bzip2 +calendar -cdb -cgi -cjk +cli +crypt +ctype +curl +curlwrappers -db2 +dba +dbase -dbmaker -dbx -debug -discard-path +doc -empress -empress-bcs -esoob -exif -fastbuild -fdftk -filepro -firebird -flatfile -force-cgi-redirect -frontbase +ftp +gd -gd-external +gdbm +gmp -hardenedphp -hyperwave-api +iconv +imap -informix -inifile -interbase -iodbc -ipv6 -java-external -java-internal -kerberos +ldap -libedit +mcal -mcve -memlimit +mhash +ming -mnogosearch -msql -mssql +mysql +ncurses +nls -oci8 -oci8-instant-client +odbc -oracle7 -overload -ovrimos -pcntl +pcre +pear -pfpro -pic +posix -postgres +readline -recode -sapdb -sasl +session -sharedext -sharedmem -snmp +sockets -solid +spell +sqlite +ssl -sybase -sybase-ct -sysvipc -threads +tiff +tokenizer +truetype -wddx +xml +xml2 -xmlrpc +xpm +xsl -yaz -zip +zlib 0 kB
[ebuild  N    ] dev-php/PEAR-PEAR-1.3.6-r1  0 kB
[ebuild  N    ] dev-php/PEAR-Archive_Tar-1.3.2  14 kB
[ebuild  N    ] dev-php/PEAR-Console_Getopt-1.2-r1  0 kB
[ebuild  N    ] dev-php/PEAR-XML_RPC-1.4.4  23 kB

Total size of downloads: 38 kB

attempthing to execute php gives no output with -v.
executing php with -n -v gives:
PHP 4.4.1-pl1-gentoo (cli) (built: Jan  3 2006 12:49:12)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

No luck in getting php to run and load anything, as far as I can tell.

David Dudley
Comment 5 Mervin 2006-01-03 19:04:04 UTC
(In reply to comment #3)
> Please also post emerge -pv =dev-lang/php-4* and /usr/lib/php4/bin/php -v,
> thanks.
> Best regards, CHTEKK.

[ebuild   R   ] dev-lang/php-4.4.1-r2  USE="apache2 berkdb bzip2 cli crypt curl dba debug exif ftp gd gdbm gmp ipv6 memlimit mhash mysql ncurses nls pcre pear posix readline session sockets spell ssl tiff tokenizer truetype xml xml2 zlib -adabas -apache -bcmath -birdstep -calendar -cdb -cgi -cjk -ctype -curlwrappers -db2 -dbase -dbmaker -dbx -discard-path -doc -empress -empress-bcs -esoob -fastbuild -fdftk -filepro -firebird -flatfile -force-cgi-redirect -frontbase -gd-external -hardenedphp -hyperwave-api -iconv -imap -informix -inifile -interbase -iodbc -java-external -java-internal -kerberos -ldap -libedit -mcal -mcve -ming -mnogosearch -msql -mssql -oci8 -oci8-instant-client -odbc -oracle7 -overload -ovrimos -pcntl -pfpro -pic -postgres -recode -sapdb -sasl -sharedext -sharedmem -snmp -solid -sqlite -sybase -sybase-ct -sysvipc -threads -wddx -xmlrpc -xpm -xsl -yaz -zip" 0 kB

and im with David here, running php4 with only -v prints nothing:
# /usr/lib/php4/bin/php --version -n
PHP 4.4.1-pl1-gentoo (cli) (built: Jan  4 2006 04:00:40) (DEBUG)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

also, with the --help arg, it prints weird stuff at the bottom
Usage: php [options] [-f] <file> [args...]
       php [options] -r <code> [args...]
       php [options] [-- args...]
  -a               Run interactively
  -c <path>|<file> Look for php.ini file in this directory
  -n               No php.ini file will be used
  -d foo[=bar]     Define INI entry foo with value 'bar'
  -e               Generate extended information for debugger/profiler
  -f <file>        Parse <file>.
  -h               This help
  -i               PHP information
  -l               Syntax check only (lint)
  -m               Show compiled in modules
  -r <code>        Run PHP <code> without using script tags <?..?>
  -s               Display colour syntax highlighted source.
  -v               Version number
  -w               Display source with stripped comments and whitespace.
  -z <file>        Load Zend extension <file>.

  args...          Arguments passed to script. Use -- args when first argument
                   starts with - or script is read from stdin
/var/tmp/portage/php-4.4.1-r2/work/php-4.4.1/Zend/zend_llist.c(38) :  Freeing 0x08482B64 (23 bytes), script=-
/var/tmp/portage/php-4.4.1-r2/work/php-4.4.1/main/SAPI.c(539) :  Freeing 0x08482B1C (24 bytes), script=-
/var/tmp/portage/php-4.4.1-r2/work/php-4.4.1/main/SAPI.c(576) :  Freeing 0x084117D4 (10 bytes), script=-

and just on a side note, i also have PHP5 installed (eselect, etc)
Comment 6 Luca Longinotti (RETIRED) gentoo-dev 2006-01-04 04:07:55 UTC
I just added new revisions of dev-lang/php to the tree, please try emering those and see if the problem persists.
@ Marvin: please emerge PHP without the "debug" USE flag, that's as far as I can see what causes the last errors you're reporting, try it.
Best regards, CHTEKK.
Comment 7 David Dudley 2006-01-04 06:54:03 UTC
I had to unmerge eselect-php to install php-toolkit (I assume that was right?).

Was hopeful that I'd have better news, but didn't work.  Still have same error "Could not startup".

php -v still displays nothing.
php -n -v says PHP 4.4.1=pl3-gentoo now.
php --help gives the proper help message.

Hope this is helpful.

Comment 8 David Dudley 2006-01-04 12:39:01 UTC
Looks like I may have discovered what was causing the problem I was having.  I was going through the installation and seeing what I had installed as extensions to PHP.

PHP-GTK was installed in php4.  Once I removed that, and removed the files from the /ext/php/cli-php4/ext* directories regarding php-gtk, things are now working correctly.  I'm currently in the process of reinstalling all the PEAR modules I had deleted.

PHP-GTK appears to cause PHP4 to 'croak' in strange and unique ways.

David Dudley
Comment 9 Mervin 2006-01-04 17:55:20 UTC
(In reply to comment #6)
> I just added new revisions of dev-lang/php to the tree, please try emering
> those and see if the problem persists.
> @ Marvin: please emerge PHP without the "debug" USE flag, that's as far as I
> can see what causes the last errors you're reporting, try it.
> Best regards, CHTEKK.

yep, its worked, thanks