Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 117143

Summary: x11-wm/wmii-3 release available
Product: Gentoo Linux Reporter: René Kraneis <rene.kraneis>
Component: Current packagesAssignee: Desktop WM Team (OBSOLETE) <desktop-wm+disabled>
Status: RESOLVED FIXED    
Severity: enhancement CC: armando, consume.noise, csimonut, dkaloper, don.fount, gemma, gentoo, hiyuh.root, insanity5902, lavish, phrexianreaper, radek, rockoo, tove, yamadharma, yann
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://wmii.de/
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: unified diff to wmii-2.ebuild
sys-apps/9base-1.ebuild
x11-wm/wmii-2.5
sys-apps/9base-1 (a few fixes)
wmii-2.5.1 bump and added to ~ppc.
sys-apps/9base-1 (added ~pcc)
Version bump
A wmii-2.5.1 ebuild for modular-X.
A ebuild for 9base-2 (Fixed CFLAGS match miss.)
A ebuild for wmii-2.5.2 (just rename)
A wmii-2.5.2 ebuild for modular-X (just rename).
x11-wm/wmii/wmii-3_pre20060501.ebuild
/x11-wm/wmii/wmii-3_pre20060504.ebuild
x11-wm/wmii/wmii-3_pre20060511.ebuild
ebuild for stable wmii-3 release
Patch to place the bar at the top of the screen
files/wmii.bash-completion
wmii-3.ebuild with bashcompletsion
x11-wm/wmii-3.1.ebuild
x11-wm/wmii-3.1-r1.ebuild
wmii.bash-completion
wmii-3.1-r2.ebuild
Patch to place the bar at the top of the screen
Bottom-bar to top-bar, wmii-3.1-r2.ebuild
wmii-3.1-r3.ebuild
wmii-3.1-r4.ebuild (security patches)
patch that protects against attackers using /tmp/ns.$user.$display for mischief
updated wmii-3.1-perm.patch against attackers abusing /tmp/ns.$user.$display
wmii-3.1.no-tmp.patch

Description René Kraneis 2005-12-29 18:44:58 UTC
wmii-2.5 is released (28.12.2005)
Comment 1 René Kraneis 2005-12-29 18:46:17 UTC
Created attachment 75761 [details, diff]
unified diff to wmii-2.ebuild
Comment 2 René Kraneis 2005-12-29 18:49:08 UTC
Created attachment 75762 [details]
sys-apps/9base-1.ebuild

As wmii seems to like its own plan9 userland tools here is the ebuild (based on wmii-2.ebuild)
Comment 3 Antek Grzymała (antoszka) 2006-01-01 11:04:21 UTC
Perhaps it would be nice to add 9base manpages to the systemwide man directory, or something like that in a future version of the ebuild.
Comment 4 Miika Linnapuomi 2006-01-04 03:26:37 UTC
Created attachment 76147 [details]
x11-wm/wmii-2.5

The patched version does not correctly set the CFLAGS (2.5 config.mk doesn't have -O0), and a few similar problems with the 9base one. Also 9base seems to depend on glibc as it fails to build on uclibc because it's math.h doesn't provide frexp. Also building it as shared instead of static by default as it uses a lot less disk space (9mb vs 900k). I'll try to add a "static" use flag, if someone doesn't do so before me..
Comment 5 Miika Linnapuomi 2006-01-04 03:28:04 UTC
Created attachment 76148 [details]
sys-apps/9base-1 (a few fixes)
Comment 6 cazzantonio 2006-01-06 05:13:43 UTC
the ebuild for wmii-2,5 doesn't successfully install for me...

this is the error:
>>> Install wmii-2.5 into /var/portage_tmp/portage/wmii-2.5/image/ category x11-wm
wmii build options:
LIBS     = -L/usr/lib -L/usr/lib -lc -lm -L/usr/X11R6/lib -lX11
CFLAGS   = -g -O2 -march=pentium-m -mfpmath=sse -pipe -fomit-frame-pointer -Wall -I. -I/usr/include -I/usr/include -I/usr/X11R6/include -DVERSION="2.5"
LDFLAGS  = -L/usr/lib -L/usr/lib -lc -lm -L/usr/X11R6/lib -lX11
CC       = i686-pc-linux-gnu-gcc
make[1]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/libcext'
AR libcext.a
built libcext
make[1]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/libcext'
make[1]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/liblitz'
AR liblitz.a
built liblitz
make[1]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/liblitz'
make[1]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/libixp'
AR libixp.a
built libixp
make[1]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/libixp'
make[1]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/libwmii'
AR libwmii.a
built libwmii
make[1]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/libwmii'
make[1]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/cmd'
built wmii commands
make[1]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/cmd'
make[1]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/cmd/wm'
make[2]: Entering directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/cmd/wm'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/cmd/wm'
built core wm
make[1]: Leaving directory `/var/portage_tmp/portage/wmii-2.5/work/wmii-2.5/cmd/wm'
installed executable files to /var/portage_tmp/portage/wmii-2.5/image//usr/bin
installed rc scripts to /var/portage_tmp/portage/wmii-2.5/image//etc/wmii-2.5
installed manual pages to /var/portage_tmp/portage/wmii-2.5/image//usr/share/man/man1
install: impossibile fare stat di `/usr/local/portage/x11-wm/wmii/files/wmii.desktop': No such file or directory

!!! ERROR: x11-wm/wmii-2.5 failed.
!!! Function src_install, Line 47, Exitcode 1
!!! wmii.desktop failed.

and this is my emerge info:
Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-gentoo-r5 i686)
=================================================================
System uname: 2.6.14-gentoo-r5 i686 Intel(R) Pentium(R) M processor 1.86GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -mfpmath=sse -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/env.d/02locale /usr/X11R6/bin/startx /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/keymaps/i386/qwerty/it.map.gz /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium-m -mfpmath=sse -pipe -fomit-frame-pointer -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.switch.ch/mirror/gentoo/ http://trumpetti.atm.tut.fi/gentoo/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ ftp://mirror.switch.ch/mirror/gentoo/ ftp://ftp.easynet.nl/mirror/gentoo/"
LANG="it_IT@euro"
LC_ALL="it_IT@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/portage_tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X a52 aalib acpi alsa audiofile avi bash-completion berkdb bitmap-fonts bzip2 cdr crypt cups curl directfb dv dvd dvdr dvdread emboss encode exif expat fam fbcon ffmpeg flac foomaticdb fortran gd gdbm gif glut gnutls gpm gstreamer gtk gtk2 idn ieee1394 imagemagick imlib ipv6 java jikes jpeg kdeenablefinal lcms ldap libg++ libwww lua mad matroska mhash mikmod mmx mng motif mp3 mpeg ncurses nls nptl offensive ogg oggvorbis opengl pam pcmcia pcre perl plotutils png ppds python quicktime readline recode sdl slang speex spell sse sse2 ssl svg svga tcltk tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb v4l vcd vorbis wmf xine xml2 xv xvid zlib linguas_it userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, MAKEOPTS
Comment 7 Torsten Veller (RETIRED) gentoo-dev 2006-01-06 05:51:22 UTC
alpiturchi:
`/usr/local/portage/x11-wm/wmii/files/wmii.desktop': No such file or directory

Please copy wmii.desktop to your overlay:
cp /usr/{,local/}portage/11-wm/wmii/files/wmii.desktop
Comment 8 hiyuh 2006-01-18 22:34:02 UTC
I had JUST exec test wmii-2.5.1 and 9base-1 on ppc.
Comment 9 hiyuh 2006-01-18 22:36:11 UTC
Created attachment 77504 [details]
wmii-2.5.1 bump and added to ~ppc.
Comment 10 hiyuh 2006-01-18 22:38:37 UTC
Created attachment 77505 [details]
sys-apps/9base-1 (added ~pcc)
Comment 11 Miika Linnapuomi 2006-01-26 09:15:40 UTC
Created attachment 78180 [details]
Version bump
Comment 12 hiyuh 2006-01-26 19:35:23 UTC
Created attachment 78252 [details]
A wmii-2.5.1 ebuild for modular-X.

This ebuild is for Modular-X version.
Comment 13 hiyuh 2006-01-26 19:50:16 UTC
Created attachment 78254 [details]
A ebuild for 9base-2 (Fixed CFLAGS match miss.)

Default config.mk's CFLAGS is not included -Os or so.
The sed regex match line for CFLAGS is fixed.
Comment 14 hiyuh 2006-01-28 03:36:27 UTC
FYI. wmii-2.5.2 is out.
It's bit of bug fixed or so.
(IMHO, Solaris support, sample of wmiirc about wmiir is changed or so.)
Just rename wmii-2.5.1.ebuild or wmii-2.5.1-r1.ebuild to
wmii-2.5.2 or wmii-2.5.2-r1 is maybe O.K.
Comment 15 hiyuh 2006-01-28 03:39:54 UTC
Created attachment 78334 [details]
A ebuild for wmii-2.5.2 (just rename)
Comment 16 hiyuh 2006-01-28 03:41:02 UTC
Created attachment 78335 [details]
A wmii-2.5.2 ebuild for modular-X (just rename).
Comment 17 konsti 2006-02-02 02:14:34 UTC
How is the 9base dependency introduced into the overlay?

/export/portage/sys-apps/9base-2/9base-2.ebuild:

sexmachine 9base-2 # ebuild 9base-2.ebuild digest
Appending /export/portage to PORTDIR_OVERLAY...
!!! /export/portage does not seem to have a valid PORTDIR structure.

Or:

/export/portage/sys-apps/9base/9base-2.ebuild:

sexmachine 9base # ebuild 9base-2.ebuild digest
>>> Generating digest file...
<<< 9base-2.tar.gz
>>> Generating manifest file...
<<< 9base-2.ebuild
<<< files/digest-9base-2
>>> Computed message digests.

But:
>>> emerge (1 of 2) sys-apps/9base-2 to /
>>> checksums files   ;-) 9base-2.ebuild
>>> checksums files   ;-) files/digest-9base-2
>>> checksums src_uri ;-) 9base-2.tar.gz
>>> Unpacking source...
>>> Unpacking 9base-2.tar.gz to /export/tmp/portage/9base-2/work

!!! ERROR: sys-apps/9base-2 failed.
Call stack:
  ebuild.sh, line 1894:   Called dyn_unpack
  ebuild.sh, line 694:   Called src_unpack
  9base-2.ebuild, line 18:   Called unpack 'unpack'

!!! 9base-2.tar.gz does not exist
!!! If you need support, post the topmost build error, and the call stack if relevant.

Now I am puzzled, how are you managing the plan9 ebuild?

Regards, Konsti
Comment 18 konsti 2006-02-02 03:04:52 UTC
Weird. emerge fetched 0 Byte .tar.gz in case of 9base-2.tar.gz and wmii-2.5.2.tar.gz.
There is

SRC_URI="http://wmii.de/download/${P}.tar.gz"

in the ebuilds though.

I fetched them by hand from there to /usr/portage/distfiles and now wmii-2.5.2 "Oranienburger defloration" (*ROFL!*) got emerged. Strange...
Comment 19 Torsten Veller (RETIRED) gentoo-dev 2006-02-27 11:01:59 UTC
FYI: i will not commit wmii-2.5.* to the tree. Next version will be -3.
Main reason is the removal of the 9base dependency (going back to sh config scripts) in wmii-3.

I will leave this bug open until -3 is in the tree so that people can find this bug easily by searching bugzilla.

Thanks for all your work.
Comment 20 Ryan 2006-04-02 09:52:29 UTC
Just a small FYI:

xsetroot should might need to be consider a dependency, in the modular xorg it isn't installed by default, and it is used called in /etc/wmii/rc.conf by default.

I am not sure if this should be a bug here, or for modular xorg
Comment 21 homry 2006-04-29 06:11:58 UTC
sorry, i know that this is no board for problems with wmii, but i couldn't find any info on the gentoo boards. i described my problem already in this thread http://forums.gentoo.org/viewtopic-t-458012.html but this seems not so easy to solve. the problem is, that my user config file in ~/.wmii-2.5 seems to get ignored. only the one in /etc/ gets used. had anyone a similar problem? any help on this maybe? thx,

homry
Comment 22 Torsten Veller (RETIRED) gentoo-dev 2006-04-29 08:45:51 UTC
homry: make sure that the files in ~/.wmii-2.5 are executable.
Comment 23 Dmitry S. Kulyabov 2006-05-03 22:41:11 UTC
Created attachment 86115 [details]
x11-wm/wmii/wmii-3_pre20060501.ebuild
Comment 24 Dmitry S. Kulyabov 2006-05-05 01:57:50 UTC
Created attachment 86189 [details]
/x11-wm/wmii/wmii-3_pre20060504.ebuild
Comment 25 Dmitry S. Kulyabov 2006-05-10 23:58:13 UTC
Created attachment 86586 [details]
x11-wm/wmii/wmii-3_pre20060511.ebuild
Comment 26 Marco Squarcina 2006-05-19 06:15:41 UTC
Created attachment 87052 [details]
ebuild for stable wmii-3 release

ebuild for wmii-3, released on 2006-05-19
Announcement here: http://wmii.de/pipermail/wmii/2006-May/001758.html

Cheers
Comment 27 Torsten Veller (RETIRED) gentoo-dev 2006-05-21 10:01:36 UTC
wmii-3 will not be in the tree until the tmp files are handled properly.

see:
http://wmii.de/irc/%23wmii-20060518  (8:53 - )
also it's never checked who owns /tmp/ns.USER.DISPLAY


Thanks for all your work.
Comment 28 Gemma L.C. Anible 2006-05-21 22:46:01 UTC
Created attachment 87228 [details, diff]
Patch to place the bar at the top of the screen

Placing the bar at the top of the screen rather than the bottom now requires a patch (see http://wmii.de/pipermail/wmii/2006-May/001791.html, follow-up at http://wmii.de/pipermail/wmii/2006-May/001810.html). I modified the ebuild and got it running, but I wondered how it'll be handled in the tree. USE flag?
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2006-05-23 02:06:24 UTC
*** Bug 134069 has been marked as a duplicate of this bug. ***
Comment 30 Marco Squarcina 2006-05-27 05:32:07 UTC
(In reply to comment #27)
> wmii-3 will not be in the tree until the tmp files are handled properly.
> 
> see:
> http://wmii.de/irc/%23wmii-20060518  (8:53 - )
> also it's never checked who owns /tmp/ns.USER.DISPLAY

It will be fixed in wmii-3.1
Hg tip already include a workaround for this problem...

I will update the ebuild as soon as 3.1 will be released

Cheers
Comment 31 Ingo Bormuth 2006-05-27 08:18:26 UTC
Created attachment 87664 [details]
files/wmii.bash-completion

Bashcompletion from
http://wmii.de/index.php?page=wmiir%20bash%20completion
Comment 32 Ingo Bormuth 2006-05-27 08:29:23 UTC
Created attachment 87666 [details]
wmii-3.ebuild with bashcompletsion

Changes:

 - install bashcompletion see attachment #87664 [details]
 - DESCRIPTION: Use original text from website
 - dodoc: add rc/welcome
Comment 33 Sawk 2006-05-29 09:41:18 UTC
The bash completion isn't work...


localhost sawk # wmiir -bash: 1: command not found
bash: 1: command not found
Comment 34 Sawk 2006-05-29 09:48:37 UTC
(In reply to comment #33)
> The bash completion isn't work...
> 
> 
> localhost sawk # wmiir -bash: 1: command not found
> bash: 1: command not found
> 


You have post the wrong wmii.bash-completion, here is the good:
http://wmii.de/pipermail/wmii/2006-April/001484.html

The problem is on  "[" and "]" ... bye :-)
Comment 35 Torsten Veller (RETIRED) gentoo-dev 2006-06-12 22:23:29 UTC
*** Bug 136589 has been marked as a duplicate of this bug. ***
Comment 36 Jakub Moc (RETIRED) gentoo-dev 2006-06-17 06:18:20 UTC
*** Bug 137072 has been marked as a duplicate of this bug. ***
Comment 37 Marco Squarcina 2006-06-17 06:27:20 UTC
Just rename https://bugs.gentoo.org/attachment.cgi?id=87052 and it works fine, obviously ;)

Cheers
Comment 38 Marco Squarcina 2006-06-17 06:29:50 UTC
(In reply to comment #37)
> Just rename https://bugs.gentoo.org/attachment.cgi?id=87052 and it works fine,
> obviously ;)

Er.. rename wmii-3.ebuild to wmii-3.1.ebuild to build the new release

Cheers
Comment 39 Armando Di Cianno 2006-06-17 08:12:18 UTC
comment #37: ... also, make sure you change the src_unpack section that does the sed filtering, especially wrt to CFLAGS (if you care about that stuff).  wmii-3 had -O2 by default (and the ebuild style filters on -O0), and wmii-3.1 has -O3 by default; simply make the change, and the rest of the build looks good.
Comment 40 Armando Di Cianno 2006-06-17 08:21:19 UTC
@torsten veller:

It looks like the bug described here:

http://wmii.de/irc/%23wmii-20060518

...specifically:

10:06 <@garbeam> sjmorgan: well, I agree with Sander that $HOME/.wmii-3 should be reserved for action files, and actually /tmp means temporary files, that's the correct namespace for such kinds of files. The alternative would be to use /tmp/.wmii.$$ as socket and /tmp/.wmiimenu.proglist.$$ as list, but this has the drawback that /tmp will be polluted

... where /tmp/.wmiimenu.proglist was not randomly generated thus created a potential for abuse, has been address in wmii-3.1.  You can grep the old and wmiirc for changes around "PROGS_FILE".

So ... can wmii-3 now go in the tree?  You have been closing other bugs related to this one, but this one isn't actually resolved yet, wrt "wmii-3 available".  I'm going to refrain from re-opening this (I used to get irritated when people did that to bugs I WONTFIX'd or RESOLVED UPSTREAM'd, when I was a dev here), but I would appreciate a response.  Thanks!
Comment 41 Marco Squarcina 2006-06-17 08:29:15 UTC
Created attachment 89394 [details]
x11-wm/wmii-3.1.ebuild

ebuild for wmii-3.1.ebuild
Fixed CFLAGS sed filter, thanks to Armando Di Cianno :)
Comment 42 Armando Di Cianno 2006-06-17 09:36:32 UTC
@Marco:

I just looked at the ebuild that was here; I've been using mine since I didn't find this bug before I tried installing.  Anways, you probably want to slap:

-e "/^X11INC/s/=.*/= \/usr\/include/" \
-e "/^X11LIB/s/=.*/= \/usr\/lib/" \

... into the middle of that sed filter as well, since /usr/X11R6 has been deprecated.
Comment 43 Armando Di Cianno 2006-06-17 09:39:54 UTC
@Marco

Oh, just noticed, you dropped the

IUSE=""

... from the ebuild, and it needs to be re-added.  I believe this is still mandatory, even if it's blank.  This may or may not still be true, but /usr/portage/skel.ebuild says it's still true, so I'm going with that. ;-)
Comment 44 Armando Di Cianno 2006-06-17 09:43:53 UTC
Created attachment 89399 [details]
x11-wm/wmii-3.1-r1.ebuild

I talk too much w/o uploading code. ;-)

Here's the ebuild with the sed filter patches, and well as the replaced IUSE=""
Comment 45 Marco Squarcina 2006-06-17 09:49:36 UTC
(In reply to comment #44)
> Created an attachment (id=89399) [edit]
> x11-wm/wmii-3.1-r1.ebuild
> 
> I talk too much w/o uploading code. ;-)
> 
> Here's the ebuild with the sed filter patches, and well as the replaced IUSE=""

As I wrote on my first post I just managed wmii-2.ebuild to work for this release. Thanks for your ebuild and tips, I didn't know about IUSE :)

Cheers
Comment 46 Ingo Bormuth 2006-06-18 04:31:38 UTC
Created attachment 89456 [details]
wmii.bash-completion

Fixed. (initialy broken by wiki)
Comment 47 Ingo Bormuth 2006-06-18 04:33:40 UTC
Created attachment 89457 [details]
wmii-3.1-r2.ebuild

Ported my changes (fixed bashcomp, descr) to newest wmii-3.1-r1.ebuild.
Comment 48 Marco Squarcina 2006-06-18 23:51:45 UTC
(In reply to comment #47)
I have just asked garbeam which is the right description, and he told me:
DESCRIPTION="wmii is a dynamic window manager for X11"

Cheers
Comment 49 Gemma L.C. Anible 2006-06-19 21:32:12 UTC
Created attachment 89597 [details, diff]
Patch to place the bar at the top of the screen

Because I can't live with a bottom bar: Top bar patch, updated for wmii-3.1. See http://wmii.de/pipermail/wmii/2006-June/002271.html.
Comment 50 Gemma L.C. Anible 2006-06-19 21:38:42 UTC
Created attachment 89598 [details, diff]
Bottom-bar to top-bar, wmii-3.1-r2.ebuild

Unified diff for the 3.1-r2 ebuild, to match the top-bar source patch.
Comment 51 Ingo Bormuth 2006-06-20 00:56:38 UTC
Created attachment 89607 [details]
wmii-3.1-r3.ebuild

How about a useflag to optionally place the bar on top ?

  - useflag "topbar" added
  - description changed (as Anselm wants it)
Comment 52 Armando Di Cianno 2006-06-22 18:50:24 UTC
Created attachment 89866 [details]
wmii-3.1-r4.ebuild (security patches)

epatch's with a patch I will upload next
Comment 53 Armando Di Cianno 2006-06-22 18:51:31 UTC
Created attachment 89867 [details, diff]
patch that protects against attackers using /tmp/ns.$user.$display for mischief

wmii-3.1-r4.ebuild uses this
Comment 54 Armando Di Cianno 2006-06-22 18:54:13 UTC
@torsten vellor

The latest patch uploaded by me takes care of consideration 2 from your comment #27 .

From the fixes in the distributed wmii-3.1 source and this patch, wmii-3.1 should be ready for inclusion in the tree.

Please respond as soon as is convenient; there are obviously a good number of us in love with this window manager, and would like to see it get into the tree.  Thanks!
Comment 55 Torsten Veller (RETIRED) gentoo-dev 2006-06-23 00:40:33 UTC
Armando, thanks for the patch. I've seen that you've sent it to wmii-hackers. So let's see what they'll do.

Ingo, I guess i will not add the barontop patch. Please convince upstream that a "movable" bar is wished.
Comment 56 Gemma L.C. Anible 2006-06-23 04:06:00 UTC
(In reply to comment #55)
 
> Ingo, I guess i will not add the barontop patch. Please convince upstream that
> a "movable" bar is wished.

Several users (myself included) have already unsuccessfully tried to convince upstream to keep the moveable bar, which is how the patch came to be. See

http://wmii.de/pipermail/wmii/2006-May/001769.html
http://wmii.de/pipermail/wmii/2006-May/001851.html
http://wmii.de/pipermail/wmii/2006-May/001898.html (and others in the same thread)

(Personally, the bottom-only bar makes a deal-breaker in an otherwise stellar window manager. Please, please add the patch.)
Comment 57 Ingo Bormuth 2006-06-23 05:56:37 UTC
(In reply to comment #55)
> Ingo, I guess i will not add the barontop patch. Please convince upstream that
> a "movable" bar is wished.

Well, I don't care for the bar's position. I just felt the patch should be optional. Upstream's positions is "if you want it on top - apply the patch". 
Comment 58 Armando Di Cianno 2006-06-23 10:03:56 UTC
Created attachment 89929 [details, diff]
updated wmii-3.1-perm.patch against attackers abusing /tmp/ns.$user.$display

- comments and input from wmii-hackers list
- better error messages
- don't depend on sed, but grep
- mkdir failing log error, too
Comment 59 Johannes Weiner 2006-07-22 05:51:40 UTC
Created attachment 92483 [details, diff]
wmii-3.1.no-tmp.patch

My patch moves all tempfiles to ${HOME}/.wmii-3. Should be applied when USE=-vanilla I think. Some people might want wmii-3 as is; give it to them...
Comment 60 Johannes Weiner 2006-07-22 17:51:08 UTC
I also wanted to remark here, that wmii-3.1 needs xmessage as RUN_DEPENDENCY. I noticed that the most current ebuild doesn't have it.
Comment 61 Anders Bo Rasmussen 2006-07-23 13:21:05 UTC
Since there is placed a socket as a tempfile, moving tempfiles to /home will make wmii stop working on systems where /home is a nfs-mount.
Comment 62 Johannes Weiner 2006-07-23 22:51:44 UTC
Yeah it really is not the best workaround. But I don't get why the files in /tmp are in some way disturbing. Same with much other programs; do they get kicked out of the portage tree? Bye, bye xorg, your tempfiles suck?
Comment 63 bartsch 2006-08-03 13:48:09 UTC
Is it an attachment list or a dumb versioning system?

Please import the ebuild into the tree and close this bug.
Comment 64 Radek Podgorny 2006-08-09 05:16:25 UTC
Reporting another success here on ~x86.
Comment 65 Don Fount 2006-10-21 18:30:04 UTC
What's the deal with this ebuild?  Is it going into Portage?  What's the holdup?
Comment 66 Torsten Veller (RETIRED) gentoo-dev 2006-10-23 14:28:34 UTC
Still this from cmd/wm/wmii:

| WMII_ADDRESS=unix!/tmp/ns.$USER.${DISPLAY%.0}/wmii export WMII_ADDRESS
|
| mkdir -m 700 /tmp/ns.$USER.${DISPLAY%.0} 2>/dev/null                                                 
| wmiiwm -a $WMII_ADDRESS & 


Easy to make wmii unresponsive by killing the socket.
Comment 67 Don Fount 2006-10-25 20:16:44 UTC
Okay, but doesn't the updated wmii-3.1-perm.patch help to ensure that other users won't be able to kill your socket?

I don't understand what your expectations are.  Please clarify what you would like done, and I'll do it.

Thanks.
Comment 68 Torsten Veller (RETIRED) gentoo-dev 2006-10-29 01:38:28 UTC
It seems other developers are interested in maintaining wmii and i am more than happy to hand it over. Reassigning to desktop-wm.

Last remark:
An "intermediate release" was announced for November:
<http://news.gmane.org/find-root.php?message_id=%3c20061010090219.GL22226%40wmii.de%3e>
A fix for the tmp file creation is in the wmii repo since Jun 2006.


WRT bug #144783, i remember it was brought to upstream several times to change this behaviour. Check before using them instead of depending on them. xmessage can be replaced by pager in term. xsetroot by any other background setting tool.
Comment 69 David Shakaryan (RETIRED) gentoo-dev 2006-10-30 23:17:25 UTC
Thanks for all the hard work and patience, folks. Getting wmii-3 into the tree is on my to do list, but I have other Gentoo-related things I want to take care of first. Hopefully, I'll get around to committing it in a week or two.
Comment 70 Jakub Moc (RETIRED) gentoo-dev 2006-11-23 01:38:01 UTC
*** Bug 155990 has been marked as a duplicate of this bug. ***
Comment 71 David Shakaryan (RETIRED) gentoo-dev 2006-12-27 23:35:17 UTC
Tada! 3.5.1 is now in the tree.

Open new bugs for any problems with the ebuild. :)
Comment 72 pankkake 2006-12-28 16:56:31 UTC
The url (http://www.wmii.net/) is wrong.
Comment 73 David Shakaryan (RETIRED) gentoo-dev 2006-12-28 18:55:53 UTC
(In reply to comment #72)
> The url (http://www.wmii.net/) is wrong.

Not in the 3.5.1 ebuild.