Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 114773

Summary: x11-libs/libX11-0.99.4 compilation failed
Product: Gentoo Linux Reporter: Toffanin <toffanin.mauro>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: log error generate during compilation

Description Toffanin 2005-12-07 09:30:20 UTC
upgrading the x11-libs/libX11-0.99.4 i get this compilation error: 
 
make[3]: *** [cmsMath.lo] Error 1 
make[3]: *** Waiting for unfinished jobs.... 
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../src -I../../include/X11 
-I../../include -I../../include/X11 -I../../include -I../../include/X11 
-I../../src/xcms -I../../src/xkb -I../../src/xlibi18n -I../../src -Wall 
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes 
-Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE 
-DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DHASXDMAUTH -D_BSD_SOURCE -march=athlon-xp 
-O2 -pipe -fno-ident -fomit-frame-pointer -momit-leaf-frame-pointer -MT 
cmsProp.lo -MD -MP -MF .deps/cmsProp.Tpo -c cmsProp.c -o cmsProp.o >/dev/null 
2>&1 
make[2]: *** [all-recursive] Error 1 
make[1]: *** [all] Error 2 
make: *** [all-recursive] Error 1 
 

Reproducible: Always
Steps to Reproduce:
1. 
2. 
3. 
 



Portage 2.0.51.22-r3 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r3, 
2.6.13-gentoo-r3 i686) 
================================================================= 
System uname: 2.6.13-gentoo-r3 i686 AMD Athlon(tm) XP 2000+ 
Gentoo Base System version 1.6.13 
dev-lang/python:     2.3.5-r2, 2.4.2 
sys-apps/sandbox:    1.2.12 
sys-devel/autoconf:  2.13, 2.59-r6 
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1 
sys-devel/binutils:  2.16.1-r1 
sys-devel/libtool:   1.5.20 
virtual/os-headers:  2.6.11-r3 
ACCEPT_KEYWORDS="x86" 
AUTOCLEAN="yes" 
CBUILD="i686-pc-linux-gnu" 
CFLAGS="-march=athlon-xp -O2 -pipe -fno-ident -fomit-frame-pointer 
-momit-leaf-frame-pointer" 
CHOST="i686-pc-linux-gnu" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=athlon-xp -O2 -pipe -fno-ident -fomit-frame-pointer 
-momit-leaf-frame-pointer" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoconfig distlocks fixpackages sandbox sfperms strict" 
GENTOO_MIRRORS="http://gentoo.ngi.it 
http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources" 
LINGUAS="it" 
MAKEOPTS="-j2 -s" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://172.16.1.2/gentoo-portage" 
USE="3dnow 3dnow2 X a52 acpi aim alsa apache2 audiofile avi bash-completion 
berkdb bitmap-fonts bmp bzip2 bzlib cairo cdr chroot crypt cups dbus 
divx4linux dri dvd dvdr eds emboss encode exif expat fam ffmpeg fftw firebird 
flac foomaticdb ftp gd gif gimp glut gpg gpm gtk gtk2 gtkhtml hal icq idn imap 
imlib java jpeg kde lcms libg++ libwww memlimit mhash mikmod mime ming mmap 
mmx mng motif mozsvg mozxmlterm mp3 mpeg msn mysql ncurses nls nptl nptlonly 
objc odbc ogg oggvorbis openal opengl pam pam_chroot pcntl pcre pdflib perl 
png posix postgres pwdb python qmail qt quicktime readline scanner sdl session 
sftplogging simplexml socket spamassassin spell sqlite sse ssl svg tiff 
truetype truetype-fonts type1-fonts udev usb vorbis win32codecs wmf x86 xine 
xml2 xmlrpc xmms xprint xv xvid yahoo zlib linguas_it userland_GNU 
kernel_linux elibc_glibc" 
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS
Comment 1 Toffanin 2005-12-07 09:38:56 UTC
Created attachment 74238 [details]
log error generate during compilation
Comment 2 Toffanin 2005-12-07 09:40:36 UTC
*forgot to mention that i'm using Xorg 7.0 modular ebuild* 
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-07 10:01:22 UTC
You didn't include the actual error, it happened above. Set MAKEOPTS to "-j1"
and try again, please.
Comment 4 Toffanin 2005-12-07 10:37:26 UTC
using '-j1' in make.conf i get this error: 
 
cmsMath.c: In function `_XcmsCubeRoot': 
cmsMath.c:94: internal compiler error: in try_split, at emit-rtl.c:3343 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://bugs.gentoo.org/> for instructions. 
Preprocessed source stored 
into /var/tmp/portage/libX11-0.99.4/temp/ccgij7p0.out file, please attach this 
to your bugreport. 
make[3]: *** [cmsMath.lo] Error 1 
make[2]: *** [all-recursive] Error 1 
make[1]: *** [all] Error 2 
make: *** [all-recursive] Error 1 
 
**the ccgij7p0.out log file is attached** 
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-07 10:52:53 UTC
Can you reproduce it at the exact same place again? Also, please paste the last
call of gcc (the full line, which probably wraps to multiple lines on your
terminal) before it.
Comment 6 Toffanin 2005-12-07 11:15:46 UTC
yes, i can reproduce this error everytime, but happen only on AMD XP machines (i
have two AMD, an XP 1800+ and an XP 2000+, same gentoo
installation/configuration, identical hardware and identical packages.* files);
i dont have this error on Pentium machine (P3 and P4) and also on my VIA
notebook i don't have this error, so i think is related only to AMD XP cpus?

here the gcc outpu, before and after the error:

 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../src -I../../include/X11
-I../../include -I../../include/X11 -I../../include -I../../include/X11
-I../../src/xcms -I../../src/xkb -I../../src/xlibi18n -I../../src -Wall
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN
-DHAS_STICKY_DIR_BIT -DHASXDMAUTH -D_BSD_SOURCE -march=athlon-xp -O2 -pipe
-fno-ident -fomit-frame-pointer -momit-leaf-frame-pointer -MT cmsMath.lo -MD -MP
-MF .deps/cmsMath.Tpo -c cmsMath.c  -fPIC -o .libs/cmsMath.o
cmsMath.c: In function `_XcmsCubeRoot':
cmsMath.c:94: internal compiler error: in try_split, at emit-rtl.c:3343
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /var/tmp/portage/libX11-0.99.4/temp/cczDziU2.out
file, please attach this to your bugreport.
make[3]: *** [cmsMath.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make: *** [all-recursive] Error 1

!!! ERROR: x11-libs/libX11-0.99.4 failed.
!!! Function x-modular_src_make, Line 130, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.
Comment 7 Toffanin 2005-12-07 11:42:29 UTC
i have found the problem: the gcc profile i686-pc-linux-gnu-3.4.4 can't compile
the package, switching to i686-pc-linux-gnu-3.3.6 now compile fine.

i think i686-pc-linux-gnu-3.4.4 profile is not safe everywhere, so now is better
if i upgrade the gcc to the last 3.4.4-r1 stable version.

hope this can help developers, thanks for the support Donnie!
Comment 8 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-07 12:06:45 UTC
I would guess your gcc build is broken then.

*** This bug has been marked as a duplicate of 20600 ***