Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 114354

Summary: hwdata-gentoo-0.2 not found on any server
Product: Mirrors Reporter: Glenn <deocypher>
Component: Server ProblemAssignee: Gentoo LiveCD Package Maintainers <livecd>
Status: VERIFIED INVALID    
Severity: normal CC: bugs.gentoo.devel
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Glenn 2005-12-03 06:55:08 UTC
Cannot download the dist file for hwdata-gentoo-0.2 because
hwdata-gentoo-0.2.tar.bz2 cannot be found in any of the gentoo mirrors. Upon
visit to the mirrors, it seems like they only have the hwdata-gentoo-0.1.

Reproducible: Always
Steps to Reproduce:
1. run 'emerge -f hwdata-gentoo'
2.
3.

Actual Results:  
>>> Downloading
http://mirror.isp.net.au/pub/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:15-- 
http://mirror.isp.net.au/pub/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving mirror.isp.net.au... 202.1.117.1
Connecting to mirror.isp.net.au|202.1.117.1|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
01:15:17 ERROR 404: Not Found.

>>> Downloading http://gentoo.oregonstate.edu/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:17--  http://gentoo.oregonstate.edu/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving gentoo.oregonstate.edu... 64.50.236.52, 64.50.238.52
Connecting to gentoo.oregonstate.edu|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://gentoo.osuosl.org/distfiles/hwdata-gentoo-0.2.tar.bz2 [following]
--01:15:21--  http://gentoo.osuosl.org/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving gentoo.osuosl.org... 64.50.238.52, 64.50.236.52
Connecting to gentoo.osuosl.org|64.50.238.52|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
01:15:25 ERROR 404: Not Found.

>>> Downloading http://ftp.gentoo.or.kr/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:25--  http://ftp.gentoo.or.kr/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving ftp.gentoo.or.kr... 218.36.126.80
Connecting to ftp.gentoo.or.kr|218.36.126.80|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
01:15:29 ERROR 404: Not Found.

>>> Downloading ftp://lug.mtu.edu/gentoo/source/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:30--  ftp://lug.mtu.edu/gentoo/source/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving lug.mtu.edu... 141.219.155.230
Connecting to lug.mtu.edu|141.219.155.230|:21... failed: Connection refused.
>>> Downloading http://gentoo.mirrored.ca/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:32--  http://gentoo.mirrored.ca/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving gentoo.mirrored.ca... 142.77.49.225
Connecting to gentoo.mirrored.ca|142.77.49.225|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
01:15:34 ERROR 404: Not Found.

>>> Downloading
http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:34-- 
http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving distro.ibiblio.org... 152.2.210.109
Connecting to distro.ibiblio.org|152.2.210.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
01:15:38 ERROR 404: Not Found.

>>> Downloading
ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:38-- 
ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving ftp.snt.utwente.nl... 130.89.175.1, 2001:610:1908:8000::175:1
Connecting to ftp.snt.utwente.nl|130.89.175.1|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/os/linux/gentoo/distfiles ... done.
==> PASV ... done.    ==> RETR hwdata-gentoo-0.2.tar.bz2 ... 
No such file `hwdata-gentoo-0.2.tar.bz2'.

>>> Downloading
http://cudlug.cudenver.edu/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:46--  http://cudlug.cudenver.edu/gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving cudlug.cudenver.edu... 132.194.22.137
Connecting to cudlug.cudenver.edu|132.194.22.137|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
01:15:48 ERROR 404: Not Found.

>>> Downloading ftp://gentoo.mirrored.ca/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:15:48--  ftp://gentoo.mirrored.ca/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving gentoo.mirrored.ca... 142.77.49.225
Connecting to gentoo.mirrored.ca|142.77.49.225|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /distfiles ... done.
==> PASV ... done.    ==> RETR hwdata-gentoo-0.2.tar.bz2 ... 
No such file `hwdata-gentoo-0.2.tar.bz2'.

Expected Results:  
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/hwdata-gentoo-0.2 to /
>>> Downloading
http://mirror.pacific.net.au/linux/Gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
--01:50:22-- 
http://mirror.pacific.net.au/linux/Gentoo/distfiles/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving mirror.pacific.net.au... 61.8.0.17
Connecting to mirror.pacific.net.au|61.8.0.17|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 668,581 (653K) [application/octet-stream]
Comment 1 Jeffrey Forman (RETIRED) gentoo-dev 2005-12-03 07:01:51 UTC
Chris,

forget to post this file?

-Jeff
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2005-12-04 05:48:48 UTC
SRC_URI="mirror://gentoo/${P}.tar.bz2
    http://dev.gentoo.org/~wolf31o2/sources/hwdata-gentoo/${P}.tar.bz2"

wolf31o2@toucan hwdata-gentoo $ ll
total 288
-rw-r--r--  1 wolf31o2 users 139481 Nov 18 14:10 hwdata-gentoo-0.1.tar.bz2
-rw-r--r--  1 wolf31o2 users 139502 Nov 30 22:28 hwdata-gentoo-0.2.tar.bz2
wolf31o2@toucan hwdata-gentoo $ pwd
/home/wolf31o2/public_html/sources/hwdata-gentoo

It is available from the secondary location.  Just because it hasn't hit the
main mirrors yet doesn't make it an error.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-12-13 15:46:49 UTC
*** Bug 115477 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-12-13 15:47:32 UTC
This thing cannot be downloaded no matter how you try, REOPEN.
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2005-12-14 06:15:54 UTC
Yes, it can.  I can verify that it works on x86/amd64/ppc/sparc/hppa/alpha using
both arch and ~arch versions of portage as SRC_URI has a 100% valid path in it.

wolf31o2@toucan ~ $ ll public_html/sources/hwdata-gentoo/
total 288
-rw-r--r--  1 wolf31o2 users 139481 Nov 18 14:10 hwdata-gentoo-0.1.tar.bz2
-rw-r--r--  1 wolf31o2 users 139502 Nov 30 22:28 hwdata-gentoo-0.2.tar.bz2

wolf31o2@workbox ~ $ wget -O /usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2
http://dev.gentoo.org/~wolf31o2/sources/hwdata-gentoo/hwdata-gentoo-0.2.tar.bz2
--09:11:07-- 
http://dev.gentoo.org/~wolf31o2/sources/hwdata-gentoo/hwdata-gentoo-0.2.tar.bz2
           => `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
Resolving dev.gentoo.org... 134.68.220.30
Connecting to dev.gentoo.org|134.68.220.30|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 139,502 (136K) [application/x-tar]

100%[====================================>] 139,502      467.37K/s

09:11:07 (466.11 KB/s) - `/usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2'
saved [139502/139502]

wolf31o2@toucan ~ $ ls -l /space/distfiles-local/hwdata-gentoo-0.2.tar.bz2
-rw-r--r--  1 wolf31o2 users 139502 Dec 14 14:14
/space/distfiles-local/hwdata-gentoo-0.2.tar.bz2

I just copied the file *again* to the mirroring location.  However, I had
alreayd done this.  Looking at the output from the OP, his portage did not even
*attempt* to download from the secondary SRC_URI location.  This is not, and can
not be *my* reposnibility that his local portage version did not even attempt to
perform the actions specified in the ebuild.

This bug is INVALID as it stands.  Do not REOPEN it.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-12-14 09:13:39 UTC
(In reply to comment #5)
> Yes, it can.  I can verify that it works on x86/amd64/ppc/sparc/hppa/alpha using
> both arch and ~arch versions of portage as SRC_URI has a 100% valid path in it.
> This bug is INVALID as it stands.  Do not REOPEN it.

Sure... Let is cycle thru about 100 mirrors that we have in the list, timeout on
a bunch of them, and then finally attempt to download from actually working
location. Wonderful solution, really rocks.

> wget -O /usr/portage/distfiles/hwdata-gentoo-0.2.tar.bz2
> http://dev.gentoo.org/~wolf31o2/sources/hwdata-gentoo/hwdata-gentoo-0.2.tar.bz2

100% irrelevant, this bug is about *emerge* cannot get the tarball, not about
wget cannot fetch it if you point it directly to the right place. 

> This is not, and can
> not be *my* reposnibility that his local portage version did not even attempt
> to perform the actions specified in the ebuild.

Sure it will try, *after* it tried all gentoo mirrors, then it actually can
finally attempt to download it from the working location. Unfortunately at that
time, about 20 minutes and bunch of mirror timeouts later, people have pressed
CTRL+C (if portage did not give up itself because of RSYNC_RETRIES), as they've
surprisingly figured out that the file is missing on the mirrors.  Hint: look at
the order of lines in SRC_URI.

This bug could have been fixed 10 days ago, just if you cared to figure out that
if mirrors have not picked up the file in 4 days (commited on Nov 30, bug filed
Dec 03), then probably something went wrong.

sigh... :=(

Works now, CLOSED.