Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 113736

Summary: net-irc/bitchx-1.1-r2 failed to compile
Product: Gentoo Linux Reporter: António Godinho <to>
Component: Current packagesAssignee: Packages in net-irc <net-irc>
Status: RESOLVED FIXED    
Severity: normal CC: bevdv, bfg-dev, gentoobugs, inc, masterdriverz, mschulkind, notellin, Olaf.Freyer, rachel, rak088+gentoobugzilla, ruckc, sascha.spreitzer, simon.dwyer, slainer68, sparc, udf4o, vapier
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 117482    
Attachments: Patches the tparm issue
Fix compilation issues with gcc 4.1
Patch for some but not all errors, REPLACES bitchx-1.1-gcc34.patch

Description António Godinho 2005-11-27 12:32:21 UTC
i686-pc-linux-gnu-gcc -I. -I/var/tmp/portage/bitchx-1.1-r2/work/BitchX/include
-I../include -I. -I./include -march=pentium4 -O2 -pipe -Wall -c ./scr-bx.c
timer.c: In function `BX_delete_timer':
timer.c:371: warning: dereferencing type-punned pointer will break
strict-aliasing rules
In file included from /var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/irc.h:104,
                 from ./scr-bx.c:14:
/var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/irc_std.h:107:1: warning:
"__inline" redefined
In file included from /usr/include/asm/sigcontext.h:4,
                 from /usr/include/bits/sigcontext.h:28,
                 from /usr/include/signal.h:333,
                 from /var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/irc.h:38,
                 from ./scr-bx.c:14:
/usr/include/linux/compiler.h:38:1: warning: this is the location of the
previous definition
gmake[1]: Leaving directory `/var/tmp/portage/bitchx-1.1-r2/work/BitchX/source'
make: *** [BitchX] Error 2
make: *** Waiting for unfinished jobs....
i686-pc-linux-gnu-gcc -I. -I/var/tmp/portage/bitchx-1.1-r2/work/BitchX/include
-I../include -I. -I./include -march=pentium4 -O2 -pipe -Wall -DSTERM_C -c ./sterm.c
In file included from /var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/irc.h:104,
                 from ./sterm.c:14:
/var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/irc_std.h:107:1: warning:
"__inline" redefined
In file included from /usr/include/asm/sigcontext.h:4,
                 from /usr/include/bits/sigcontext.h:28,
                 from /usr/include/signal.h:333,
                 from /var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/irc.h:38,
                 from ./sterm.c:14:
/usr/include/linux/compiler.h:38:1: warning: this is the location of the
previous definition
./sterm.c:95: error: conflicting types for 'tparm'
/usr/include/ncurses.h:740: error: previous declaration of 'tparm' was here
./sterm.c:95: error: conflicting types for 'tparm'
/usr/include/ncurses.h:740: error: previous declaration of 'tparm' was here
./sterm.c: In function `term_init':
./sterm.c:880: warning: unused variable `tmp'
gmake[1]: *** [sterm.o] Error 1
gmake[1]: Leaving directory `/var/tmp/portage/bitchx-1.1-r2/work/BitchX/source'
make: *** [scr-bx] Error 2

!!! ERROR: net-irc/bitchx-1.1-r2 failed.
!!! Function src_compile, Line 100, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.
Comment 1 António Godinho 2005-11-27 12:32:36 UTC
gandalf ~ # emerge --info
Portage 2.0.53_rc7 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r3,
2.6.14.2-grsec i686)
=================================================================
System uname: 2.6.14.2-grsec i686 Intel(R) Pentium(R) 4 CPU 1600MHz
Gentoo Base System version 1.12.0_pre11
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoclean autoconfig ccache distlocks fixpackages sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.gentoo-pt.org/pub/gentoo/
http://darkstar.ist.utl.pt/gentoo/ ftp://mirrors1.netvisao.pt/gentoo/
http://gentoo.felisberto.net/
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 acl apache apache2 apm atm audiofile avi berkdb bitmap-fonts bzip2
crypt curl eds emboss encode expat fam foomaticdb fortran gd gif gpm gstreamer
gtk2 idn imagemagick imap jpeg lcms libg++ libwww mad mhash mmx mng motif mpeg
mysql ncurses nls nptl ogg opengl pam pcre perl php png python qt quicktime
readline samba sdl server slang spell sqlite sse ssl svga tcltk tcpd threads
tiff truetype truetype-fonts type1-fonts udev usb xml xml2 xv zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 2 giggles1 2005-12-18 09:11:03 UTC
I also have this problem
Comment 3 Jouni Rinne 2006-01-07 05:16:36 UTC
Same problem, same error, with gcc-3.4.5
Comment 4 António Godinho 2006-01-18 03:59:57 UTC
Still no resolution?!
Comment 5 giggles1 2006-01-18 15:24:25 UTC
I don't know why they haven't posted a fix yet. Deleting the extern tparm declaration in sterm.c will allow it to compile and run. 
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-02-01 05:29:06 UTC
*** Bug 121165 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-02-17 02:02:53 UTC
*** Bug 123143 has been marked as a duplicate of this bug. ***
Comment 8 Greg Watson (linuxkrn) 2006-03-16 17:51:41 UTC
I'm still getting this problem, and it's been open for 4 months!  What's the problem here?
Comment 9 Guy 2006-03-18 13:53:12 UTC
No maintainer.

If someone could develop a patch and post it here, it would be helpful for the rest of us who can't program. :-D

And helpful for the developers too I imagine.
Comment 10 Matt Weber 2006-03-21 10:32:03 UTC
Oh, I suppose it's already fixed. NM.
Comment 11 Tom Fredrik Blenning Klaussen 2006-03-24 10:56:25 UTC
Created attachment 83029 [details, diff]
Patches the tparm issue

This patch takes care of the compile problem.
It's not been extensively tested, but it's my belief that it should be universally working.

Place the patch in your bitchx/files dir
And then add:
epatch ${FILESDIR}/extern_tparm.patch
to the end of src_unpack() in your ebuild.
Comment 12 Joe Millenbach 2006-05-29 00:41:08 UTC
Has been entered in BitchX.org's bug database for over a year now.  I'm guessing they won't be fixing it anytime soon.

Also I get a different failure that looks similar (redefinition of a value)...

"x86_64-pc-linux-gnu-gcc -I. -I/var/tmp/portage/bitchx-1.1-r2/work/BitchX/include -I../include -I. -I./include -march=athlon64 -O2 -pipe -Wall -c dcc.c
ctcp.c:179: error: static declaration of 'ctcp_type' follows non-static declaration
/var/tmp/portage/bitchx-1.1-r2/work/BitchX/include/ctcp.h:59: error: previous declaration of 'ctcp_type' was here"
Comment 13 Kfir Ozer 2006-06-01 00:09:28 UTC
the tparm patch fixes the problem thanks alot!
------------------------------------
Portage 2.1_rc3-r3 (default-linux/amd64/2006.0, gcc-3.4.5, glibc-2.4-r3, 2.6.16-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r8 x86_64 AMD Sempron(tm) Processor 2800+
Gentoo Base System version 1.12.0
ccache version 2.4 [enabled]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache confcache distlocks keeptemp keepwork metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa apache2 automount avi bash-completion berkdb bidi bitmap-fonts bluetooth bzip2 cdparanoia cdr cli crypt ctype cups curl curlwrappers dio directfb dri dv dvd dvdr dvdread eds emboss emul-linux-x86 encode fam fbcon foomaticdb fortran ftp gd gif glut gmp gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml icecast icq imagemagick imap imlib innodb ipv6 isdnlog jack java javascript jikes joystick jpeg jpeg2k kde lcms ldap lesstif libwww lm_sensors logrotate lzw lzw-tiff mbox memlimit mikmod mime mozilla mp3 mpeg mpm-threadpool msn mysql ncurses nls nptl nptlonly nsplugin objc objc++ ocaml ogg openal opengl pam pcntl pcre pdf pdflib perl php png pppd python qt quicktime readline reflection samba sasl scanner sdl server session sharedext slang sndfile snmp sox spell spl sqlite ssl svg symlink tcltk tcpd threads tidy tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd videos vorbis xanim xine xinerama xml xml2 xorg xpm xprint xv xvid zlib elibc_glibc kernel_linux userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 14 António Godinho 2006-06-06 06:58:15 UTC
The patch works perfectly... don't understand why this haven't been merged yet...
Comment 15 ruckc 2006-06-15 04:04:28 UTC
I only have a partial patch visible here ... the comment if only part of the comment.  Can someone repost this patch?

Error message w/patch:

Calculating dependencies... done!
>>> Emerging (1 of 1) net-irc/bitchx-1.1-r2 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking ircii-pana-1.1-final.tar.gz ;-)
>>> Unpacking source...
>>> Unpacking ircii-pana-1.1-final.tar.gz to /var/tmp/portage/bitchx-1.1-r2/work
 * Applying bitchx-1.1-hebrew.patch ...                                                                                                                [ ok ]
 * Applying bitchx-1.1-freenode.patch ...                                                                                                              [ ok ]
 * Applying bitchx-1.1-gcc34.patch ...                                                                                                                 [ ok ]
 * Applying fPIC.patch ...                                                                                                                             [ ok ]

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/net-irc/bitchx/files/extern-tparm.patch
 *   ( extern-tparm.patch )


!!! ERROR: net-irc/bitchx-1.1-r2 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_unpack
  ebuild.sh, line 711:   Called src_unpack
  bitchx-1.1-r2.ebuild, line 45:   Called epatch '/usr/local/portage/net-irc/bitchx/files/extern-tparm.patch'
  eutils.eclass, line 190:   Called die

!!! Cannot find $EPATCH_SOURCE!
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! This ebuild is from an overlay: '/usr/local/portage'
Comment 16 Richard Fish 2006-07-01 18:28:13 UTC
Created attachment 90657 [details, diff]
Fix compilation issues with gcc 4.1

Looks like it also has problems with gcc 4.1, giving errors like #12.

The attached bitchx-1.1-gcc41.patch should fix those.
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2006-07-04 10:33:04 UTC
*** Bug 139210 has been marked as a duplicate of this bug. ***
Comment 18 Rachel Greenham 2006-07-04 10:58:31 UTC
(In reply to comment #17)
> *** Bug 139210 has been marked as a duplicate of this bug. ***
> 

Not quite identical, as this was happening attempting to merge net-irc/bitchx-1.1-r1 (currently marked as stable) and this bug appears to be relating to -r2. Also, it only occurs when trying to do so with ncurses-5.5 (also currently marked as stable). It's happy with ncurses-5.4 on the same gcc version (3.4.6-r1)

I did try emerging bitchx-1.1-r2 but it does still exhibit the same problem.

Can confirm it also fails on my x86 system. Same versions.
Comment 19 Sascha Spreitzer 2006-07-24 02:49:20 UTC
Portage 2.1-r1 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r13 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r13 x86_64 AMD Athlon(tm) 64 Processor 3700+
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -pipe -march=athlon64"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa apache2 avi berkdb bitmap-fonts bzip2 cli crypt cups curl dlloader dri eds emboss encode foomaticdb fortran ftp gif gpm gstreamer gtk gtk2 imap imlib ipv6 isdnlog jpeg logrotate lzw lzw-tiff mp3 mpeg mysql mysqli ncurses nls nptl opengl pam pcre pdflib perl php png posix pppd python qt qt3 qt4 quicktime readline reflection sdl session sockets spell spl ssl sysvipc tcpd threads tiff truetype truetype-fonts type1-fonts usb vhosts xml xmlreader xmlrpc xorg xpm xv zip zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en linguas_de userland_GNU video_cards_radeon video_cards_vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS


can confirm tparm issue on amd64 with gcc 3.4.6-r1
Comment 20 Charlie Shepherd (RETIRED) gentoo-dev 2006-08-22 06:53:06 UTC
Should this bug depend on 117482?
Comment 21 SpanKY gentoo-dev 2006-09-03 23:01:48 UTC
*** Bug 146152 has been marked as a duplicate of this bug. ***
Comment 22 Randall Nortman 2006-09-04 03:47:29 UTC
Created attachment 95947 [details]
Patch for some but not all errors, REPLACES bitchx-1.1-gcc34.patch

This is the patch I posted on the bug I filed (#146152), which was marked a dup of this bug.  This patch incorporates and replaces bitchx-1.1-gcc34.patch.  Don't try to apply them both, because that will fail.  This also incorporates the tparm fix, so I imagine you shouldn't try to apply that along with this one, either.
Comment 23 Andrew Debugski 2006-09-04 11:16:53 UTC
I had #12 and tparm problems. Aplying both patches makes bitchx work again. Thank you!
Comment 24 Markus Ullmann (RETIRED) gentoo-dev 2006-09-05 14:17:52 UTC
(In reply to comment #23)
> I had #12 and tparm problems. Aplying both patches makes bitchx work again.
> Thank you!
> 

Can you compile it as one patch so we talk about the same patch here? ;)
Comment 25 SpanKY gentoo-dev 2006-09-06 00:02:55 UTC
ok, 1.1-r3 now in portage with fixes

thanks everyone
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2006-09-22 03:07:11 UTC
*** Bug 148622 has been marked as a duplicate of this bug. ***