Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 113281

Summary: media-video/vlc-0.8.1-r1 won't build against media-video/ffmpeg-0.4.9_p20051120
Product: Gentoo Linux Reporter: Dan Check <check>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: minor    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Dan Check 2005-11-22 12:40:31 UTC
media-video/ffmpeg-0.4.9_p20051120 is ~x86, media-video/vlc-0.8.1-r1 is stable,
so this is low priority.  

media-video/vlc-0.8.2.* builds fine against the latest ffmpeg.


Reproducible: Always
Steps to Reproduce:

Actual Results:  
From the compile:

Making all in ffmpeg
make[5]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
make[6]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../..   -DSYS_LINUX
-I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin
ffmpeg` -Wsign-compare -Wall -march=i686 -msse -mmmx -mfpmath=sse -Os -pipe
-fomit-frame-pointer -pipe -MT libffmpeg_a-ffmpeg.o -MD -MP -MF
".deps/libffmpeg_a-ffmpeg.Tpo" \
  -c -o libffmpeg_a-ffmpeg.o `test -f 'ffmpeg.c' || echo './'`ffmpeg.c; \
then mv -f ".deps/libffmpeg_a-ffmpeg.Tpo" ".deps/libffmpeg_a-ffmpeg.Po"; \
else rm -f ".deps/libffmpeg_a-ffmpeg.Tpo"; exit 1; \
fi
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../..   -DSYS_LINUX
-I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin
ffmpeg` -Wsign-compare -Wall -march=i686 -msse -mmmx -mfpmath=sse -Os -pipe
-fomit-frame-pointer -pipe -MT libffmpeg_a-video.o -MD -MP -MF
".deps/libffmpeg_a-video.Tpo" \
  -c -o libffmpeg_a-video.o `test -f 'video.c' || echo './'`video.c; \
then mv -f ".deps/libffmpeg_a-video.Tpo" ".deps/libffmpeg_a-video.Po"; \
else rm -f ".deps/libffmpeg_a-video.Tpo"; exit 1; \
fi
video.c: In function `ffmpeg_NewPictBuf':
video.c:183: error: structure has no member named `frame_rate'
video.c:183: error: structure has no member named `frame_rate_base'
video.c:185: error: structure has no member named `frame_rate'
video.c:186: error: structure has no member named `frame_rate_base'
video.c: In function `DecodeVideo__ffmpeg':
video.c:634: error: structure has no member named `frame_rate'
video.c:638: error: structure has no member named `frame_rate_base'
video.c:639: error: structure has no member named `frame_rate'
distcc[9478] ERROR: compile video.c on 192.168.0.108 failed
make[6]: *** [libffmpeg_a-video.o] Error 1
make[6]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
make[5]: *** [all-modules] Error 1
make[5]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec'
make[3]: *** [all] Error 2
make[3]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1'
make: *** [all] Error 2

!!! ERROR: media-video/vlc-0.8.1-r1 failed.
!!! Function src_compile, Line 197, Exitcode 2
!!! make of VLC failed
!!! If you need support, post the topmost build error, NOT this status message.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-11-22 12:42:26 UTC

*** This bug has been marked as a duplicate of 113231 ***
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:53:43 UTC
Reopening to change duplicate... 
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:54:10 UTC
actually reopen  
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:54:43 UTC

*** This bug has been marked as a duplicate of 108884 ***