Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 112529

Summary: vbetool - mmap /dev/mem: Permission denied
Product: Gentoo Linux Reporter: Dean Pierce <piercede>
Component: [OLD] Core systemAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Dean Pierce 2005-11-14 10:40:31 UTC
When I run the program vbetool (which I need to properly suspend my laptop to
ram), I get the error "mmap /dev/mem: Permission denied".

Also it leaves a message in dmesg that says "program vbetool is using
MAP_PRIVATE, PROT_WRITE mmap of VM_RESERVED memory, which is deprecated.  Please
report this to".

I think the problem is that I am using the mm-sources (my root is reiser4, so I
can't test with other sources in portage).  I have tested this on 2.6.14-rc5-mm1
through 2.6.14-mm2 with the same results.  I have also tried many configs, and I
modified the vbetool code so it doesnt leave the error in dmesg, but the results
are the same.  I got the same results for vbetool 0.2 and 0.3 (the only ebuilds
in portage for vbetool)

Reproducible: Always
Steps to Reproduce:
(as root)
1. emerge vbetool
2. vbetool
3. hibernate

Actual Results:  
mmap /dev/mem: Permission denied  is printed to the screen.
If I try to run the hibernate script, the screen flickers a bit, and then aborts
because the vbetool command fails.

Expected Results:  
suspend to ram

All my configs (including emerge info) can be found at

Gentoo Base System version 1.12.0_pre10
Portage 2.0.53_rc7 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r3,
2.6.14-mm2 i686)
System uname: 2.6.14-mm2 i686 Intel(R) Pentium(R) M processor 2.00GHz
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=pentium4"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=pentium4"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 X alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bzip2 crypt
cups dts eds emboss encode esd ethereal expat fam foomaticdb fortran gd gdbm gif
glut gmp gnome gpm gstreamer gtk gtk2 guile idn imagemagick imap imlib ipv6 java
jpeg kde lcms libg++ libwww mad mikmod mmx mng motif mp3 mpeg mysql ncurses nls
ogg oggvorbis opengl oss pam pcre pdflib perl php png python qt quicktime
readline sdl spell sse sse2 ssl tcpd tetex tiff truetype truetype-fonts
type1-fonts udev usb vorbis xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-11-14 12:34:17 UTC
(In reply to comment #0)
> I think the problem is that I am using the mm-sources

Looks pretty much like that -

Anyway, mm-sources is not a supported kernel - see

Feel free to reopen if you are able to reproduce the problem with a supported
kernel or if you have a sane patch. Thanks.
Comment 2 Joel Kaasinen 2005-12-06 12:34:28 UTC
Could someone reopen this, as i am able to reproduce it with 2.6.15-rc1.