Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 112123

Summary: madwifi-driver-0.1_pre20051031 is marked as masked, but portage ignores the mask
Product: Gentoo Linux Reporter: Mike Auty (RETIRED) <ikelos>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Mike Auty (RETIRED) gentoo-dev 2005-11-10 15:36:18 UTC
I recently synced portage, new versions were out for both madwifi-driver and
madwifi-tools, 0.1_pre20051031.  I built both of these, then synced again the
next day and saw that madwifi-tools needed to be downgraded.  I thought it odd
that only the tools were rolled back, but updated it anyway.  I then tried my
wireless card later that evening, and discovered that the new driver didn't show
up in /proc/net/wireless, so wanted to step back to the recent 20051004 ebuild I
made myself and maintain in a personal overlay.  I added a line to
/etc/portage/package.mask, but the package simply wouldn't mask.  I thought it
was a typo and pasted the line in, still no luck.  On a hunch I checked the
recent /usr/portage/profiles/package.mask and saw that it was supposed to have
already been masked in there with the tools.  Something rather odd is going on.
 Eix believes the package should be masked, so it appears it's only portage that
hasn't got the idea.  A quick fix would be to pull the ebuilds from the
repository, but this definitely suggests a bug in portage's mask reading system.
 I have no idea whereabouts or why (it's not overly long pre values since the
tools were successfully masked off, I can only think it's a total length
problem, but that's a guess).  Anyway, any ideas or solutions would be welcome...

Reproducible: Always
Steps to Reproduce:
1. Sync up portage
2. Attempt to emerge madwifi-driver

Actual Results:  
Version 0.1_pre20051031 attempts to install even though it should be masked.

Expected Results:  
The next lowest version (in my case a personal ebuild from my overlay) should
attempt to install.

Portage 2.0.53_rc7 (default-linux/x86/2005.0, gcc-3.4.4-vanilla, glibc-2.3.5-r3,
2.6.14 i686)
System uname: 2.6.14 i686 Intel(R) Pentium(R) M processor 1400MHz
Gentoo Base System version 1.12.0_pre10
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r2
CFLAGS="-mtune=pentium4 -march=pentium4 -O3 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-mtune=pentium4 -march=pentium4 -O3 -fomit-frame-pointer"
FEATURES="autoconfig ccache cvs distlocks sandbox sfperms strict"
USE="x86 GAPING_SECURITY_HOLE X aalib acl acpi adns alsa animation audiofile avi
bash-completion berkdb bitmap-fonts bluetooth boundschecking browserplugin bzip2
cairo cdr crypt cups dbus dlloader dri dvb dvd eds emboss encode ethereal exif
expat fam ffmpeg flac foomaticdb fortran freetds gd gdbm gif glitz glut gmp
gnome gnutls gps gstreamer gtk gtk2 gtkhtml hal hardened idn imagemagick ipv6
java john jpeg junit lcms ldap libg++ libwww lua mad madwifi mailwrapper mikmod
mmx mng motif mozilla mp3 mpeg mscash mssql mysql ncurses nls nptl nptlonly ntlm
ogg oggvorbis opengl pam pcmcia pcre pdflib pic pie plot png postgres pylibpcap
python quicktime readline recode samba sasl sdl slang slp smux snmp sox spell
sse sse2 ssl svg tcpd tetex theora threads tiff truetype truetype-fonts
type1-fonts udev usb vorbis win32codecs xine xml2 xv xvid zlib userland_GNU
kernel_linux elibc_glibc"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-11-10 15:40:11 UTC
Please, post the output of 'grep madwifi /etc/portage/package*
Comment 2 Mike Auty (RETIRED) gentoo-dev 2005-11-10 15:52:31 UTC
Ok, now I feel very, very stupid.  Thanks very much, sure enough I had it in my
package.unmask as just a global unmask rather than a specific version unmask. 
And unmasking takes precidence over masking, even in /etc/portage.  Sorry to
waste your time like that...