Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 111376

Summary: x11-misc/smeg is now x11-misc/alacarte
Product: Gentoo Linux Reporter: Gour <gour>
Component: New packagesAssignee: John N. Laliberte (RETIRED) <allanonjl>
Status: RESOLVED FIXED    
Severity: enhancement CC: eva, gnome, jean.regisser, lanius, leio, matrixhax0r, matteo-ml, maxxer, spamlover, tom.gl, tristan, will, xoen.gnu
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: x11-misc/alacarte-0.8 ebuild
alacarte-0.8.ebuild
x11-misc/alacarte-0.8.ebuild using patch
little patch for the "no uri for icon" bug
alacarte-0.9.ebuild

Description Gour 2005-11-03 10:26:51 UTC
Hi!

The x11-misc/smeg application changed its name and now it is alacarte.

Latest version is alacarte-0.8.

Pls. add it to portage.

Sincerely,
Gour


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Gour 2005-11-03 10:28:39 UTC
Created attachment 72041 [details]
x11-misc/alacarte-0.8 ebuild

Hi!

Pls. see in the attachment new ebuild for newly named application - alacarte
which replaces old x11-misc/smeg.

I built it on amd64.

Sincerely,
Gour
Comment 2 TGL 2005-11-20 08:57:13 UTC
Created attachment 73254 [details]
alacarte-0.8.ebuild

Here is an improved ebuild which uses distfiles.eclass (for pyc/pyo generation
and cleanup, installation of doc files, etc.). 

It also fixes dependencies (require the right versions, add gnome-python, move
what is runtime-only to RDEPEND). Note that i've required >=pygtk-2.8.0-r2
because in previous version glade support was only optionnal (the alternative
being to depend on >=2.6, but with a pkg_setup check for glade... kind of
ugly).

Oh, and i have removed the "gnome" USE flag and the optionnal gnome-menus
dependency, because i just don't see its benefit. Sure, if you think i'm wrong,
well, you know how to re-add it...
Comment 3 Gour 2005-11-21 02:13:38 UTC
> Sure, if you think i'm wrong, well, you know how to re-add it...

Thank you for enhancing ebuild. My intention was more to bring focus that
application changed its name and ebuild is (was) more for in-house :-)

Let me try yours ;)

Sincerely,
Gour
Comment 4 Paul Chatzidimitriou 2006-02-02 03:52:14 UTC
a proposal made by bluefox81 [url=http://forums.gentoo.org/viewtopic-p-3078450.html#3078450]here[/url] fix a problem about menu entries that doesn't have an icon and then when right click them and select the available options such as properties the window isn't appear.Can someone make a patch for the ebuild?
Comment 5 Gilles Dartiguelongue gentoo-dev 2006-02-26 08:04:08 UTC
Created attachment 80769 [details]
x11-misc/alacarte-0.8.ebuild using patch

new ebuild with patch proposed on gentoo forums.
Comment 6 Gilles Dartiguelongue gentoo-dev 2006-02-26 08:06:40 UTC
Created attachment 80770 [details, diff]
little patch for the "no uri for icon" bug

this patch corrects the problem encountered when editing an entry which icon path is empty.
Comment 7 Pacho Ramos gentoo-dev 2006-03-14 11:23:15 UTC
Please add alacarte to portage tree

Thanks :)
Comment 8 Pacho Ramos gentoo-dev 2006-04-08 04:25:43 UTC
Why hasn't alacarte been added to portage tree?

Thanks a lor for information :)
Comment 9 Tristan Heaven (RETIRED) gentoo-dev 2006-04-26 23:45:54 UTC
Created attachment 85592 [details]
alacarte-0.9.ebuild

You need to patch gnome-menus 2.14 to use this version.
http://bugzilla.gnome.org/show_bug.cgi?id=336841
Comment 10 Pacho Ramos gentoo-dev 2006-05-27 09:17:51 UTC
Why has it not been added to portage tree?

Thanks a lot :)
Comment 11 Gilles Dartiguelongue gentoo-dev 2006-06-05 23:35:38 UTC
hem, Ubuntu Dapper Drake ship it by default now. I known functionality is pretty much the same as right clicking on the menu-bar but it provides some more.

If you don't want to continue maintening the ebuild, what about CC the gnome-herd ? (Sadly, I think they'll refuse to take care of this)
Comment 12 David Li 2006-07-26 13:27:53 UTC
I think the problem with pushing this build through is the patch for gnome-menus mentioned in Comment #9. The gnome team is probably waiting for the next release of gnome-menus that will incorperate the patch. The other distros have jumped the gun and applied the patch to gnome-menus-2.14.0
Comment 13 David Li 2006-09-12 15:12:05 UTC
Anyways, this has been fixed ever since gnome 2.16 was merged into portage. Just unmask and grab x11-mis/alacarte-0.10.0
Comment 14 John N. Laliberte (RETIRED) gentoo-dev 2006-09-13 06:18:42 UTC
fixed with 2.16