Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 106268

Summary: emerge media-video/mplayer-1.0_pre7-r1 failed
Product: Gentoo Linux Reporter: mike <gentoo2>
Component: [OLD] UnspecifiedAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED INVALID    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description mike 2005-09-17 05:48:55 UTC
This reproduces the problem:
"# emerge mplayer"

Currently mplayer (of an older version) is installed and runs fine.

Reproducible: Always
Steps to Reproduce:
1. emerge mplayer

Actual Results:  
The emerge stops without performing the emerge.
---
libao2/libao2.a(ao_sdl.o)(.text+0xfa): In function `reset':
: undefined reference to `SDL_PauseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x24c): In function `init':
: undefined reference to `SDL_OpenAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x3bb): In function `init':
: undefined reference to `SDL_PauseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x3d6): In function `init':
: undefined reference to `SDL_PauseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x3dd): In function `init':
: undefined reference to `SDL_PauseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x4f9): In function `uninit':
: undefined reference to `SDL_CloseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x119): In function `reset':
: undefined reference to `SDL_PauseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x516): In function `audio_pause':
: undefined reference to `SDL_PauseAudio'
libao2/libao2.a(ao_sdl.o)(.text+0x523): In function `audio_resume':
: undefined reference to `SDL_PauseAudio'
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1

!!! ERROR: media-video/mplayer-1.0_pre7-r1 failed.
!!! Function src_compile, Line 435, Exitcode 2
!!! Failed to build MPlayer!
!!! If you need support, post the topmost build error, NOT this status message.


Expected Results:  
The emerge should work.

# emerge --info
Portage 2.0.51.22-r2 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.11-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.11-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3800+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -pipe -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://cudlug.cudenver.edu/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X aalib alsa apache2 arts avi berkdb bitmap-fonts bonobo cdparanoia
cdr crypt cups curl directfb dts dvd eds emboss encode esd fam fbcon foomaticdb
fortran gd ggi gif gnome gpm gstreamer gtk gtk2 gtkhtml guile hal howl
imagemagick imlib ipv6 jack java jpeg jpg junit kde libcaca libwww lirc lzw
lzw-tiff mad matroska motif mozilla mp3 mpeg mysql mythtv nas ncurses network
nls nvidia ogg oggvorbis opengl pam pdflib perl png python qt quicktime readline
real samba sdl spell ssl tcpd tetex theora tiff truetype-fonts type1-fonts
unicode usb userlocales v4l v4l2 vorbis xine xinerama xml xml2 xmms xpm xv xvid
xvmc zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY






this is from /var/log/emerge.log:
-------
1126960602: Started emerge on: Sep 17, 2005 07:36:42
1126960602:  *** emerge  mplayer
1126960603:  >>> emerge (1 of 1) media-video/mplayer-1.0_pre7-r1 to /
1126960603:  === (1 of 1) Cleaning
(media-video/mplayer-1.0_pre7-r1::/usr/portage/media-video/mplayer/mplayer-1.0_pre7-r1.ebuild)
1126960606:  === (1 of 1) Compiling/Merging
(media-video/mplayer-1.0_pre7-r1::/usr/portage/media-video/mplayer/mplayer-1.0_pre7-r1.ebuild)
1126960867:  *** terminating.
1126961188: Started emerge on: Sep 17, 2005 07:46:28
1126961188:  *** emerge  info
1126961188:  *** terminating.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-17 06:29:17 UTC
So don't put noaudio into USE when emerging libsdl.
Comment 2 mike 2005-09-17 07:14:42 UTC
Thanks for the reply.  However when I check the USE flags for libsdl I see that
-noaudio is there.  When I did the emerge on libsdl again and then tried the
emerge on mplayer it works.

So there may be a problem some where in some dependency.  I would have expected
whatever changed to rebuild libsdl if it was needed.

----------
# emerge -av libsdl

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-libs/libsdl-1.2.8-r1  +X +aalib +alsa +arts -dga +directfb
+esd +fbcon +ggi +libcaca +nas -noaudio -noflagstrip -nojoystick -novideo
+opengl -oss -pic (-svga) +xinerama +xv 0 kB
Comment 3 mike 2005-09-17 07:15:39 UTC
maybe it was not clear in my last post - there is no remaining issue or problem.

thanks.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-09-17 07:16:35 UTC
(In reply to comment #3)
> maybe it was not clear in my last post - there is no remaining issue or problem.

Good. Closing then, thanks for reporting back.