Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 105007

Summary: ALPS touchpad broken in every kernel after 2.6.10
Product: Gentoo Linux Reporter: Stuart Shelton <srcshelton>
Component: [OLD] Core systemAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: 2005.1   
Hardware: x86   
OS: Linux   
URL: http://bugzilla.kernel.org/show_bug.cgi?id=4281
Whiteboard:
Package list:
Runtime testing required: ---

Description Stuart Shelton 2005-09-06 05:37:51 UTC
... following on from Bug 84657 (which is marked RESOLVED)

I've just installed Linux 2.6.13-gentoo, and the ALPS touchpad problem is still
evident.

To recap, this is kernel.org Bug 4281:

* In a text-mode console, the touchpad randomly taps during movement and is
incapable of selecting large areas of text (I run a 1400x1050 text-console, and
after selecting over about 1/3 of this strange selection behavior occurs)
* In a text-mode console, moving the cursor around the screen leaves
single-character artifacts where a character is left in reverse-video (as if the
cursor was still positioned over it) after the cursor has moved on.
* In X using any of the *PS/2 drivers, dragging and tapping don't work, and the
mouse randomly clicks during movement.

This is when the kernel is started with "psmouse.proto=ps2" - IIRC, without this
the trackpad doesn't work.

I know that the synaptics driver for X is available - but this only solves the
problems in X and is very difficult to configure correctly.  Plus, I don't think
I should need a third-party driver to get something as simple as a PS/2 pointing
device to work reliably.

Could Gentoo developers put pressure on kernel developers to let them know that
this driver has now been broken for 3 kernel versions?  Infact, a patch to
revert the ALPS driver to its state as of 2.6.10 would be brilliant!
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-06 07:29:08 UTC
I'll reopen the original bug, please post there.

*** This bug has been marked as a duplicate of 84657 ***