Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 103174

Summary: Modular Xorg: Conflicting /usr/share/fonts/misc/fonts.{dir,cache,scale}
Product: Gentoo Linux Reporter: Andrej Kacian (RETIRED) <ticho>
Component: New packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: normal CC: betelgeuse, brebs, flash3001, radek, sanchan, sandro.bonazzola
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 112004    

Description Andrej Kacian (RETIRED) gentoo-dev 2005-08-20 13:07:55 UTC
Both media-fonts/fonts-misc-misc and media-fonts/font-cursor-misc install
/usr/share/fonts/misc/fonts.dir
/usr/share/fonts/misc/fonts.scale
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-08-20 13:23:33 UTC
So we have a record:

20:09 <@spyderous> Ticho: there isn't really a good solution to that, because
                   we need to regenerate those files for each package installed
                   to that directory
20:10 <@Ticho> spyderous: then don't install those files and have it generated
               after all files are installed into image
20:10 <@Ticho> spyderous: ah, i see now
20:10 <@spyderous> people will complain about that too, because then the files
                   won't be owned by anything
20:10 <@Ticho> spyderous: isn't there something like collision protect mask?
20:11 <@spyderous> Ticho: nope
20:11 <@spyderous> at least not according to grep
20:12 <@spyderous> the optimal solution would be a pkg_postrm check whether any
                   font* packages are still installed, and if not, delete
                   fonts.*
20:12 <@spyderous> but that still feels like a hack
20:12 <@Ticho> that doesn't sound right
Comment 2 Joshua Baergen (RETIRED) gentoo-dev 2005-08-22 18:10:08 UTC
Is there any way to add ownership to a location/file so that collision-protect
no longer complains?
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2005-12-27 09:47:55 UTC
*** Bug 116626 has been marked as a duplicate of this bug. ***
Comment 4 Joshua Baergen (RETIRED) gentoo-dev 2005-12-27 09:48:05 UTC
*** Bug 116624 has been marked as a duplicate of this bug. ***
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2006-01-02 22:13:22 UTC
We've got a cleanup function in the modular eclass now so we can probably delete these files from IMAGE for any font types for which they will be autogenerated. That will prevent most of the ownership problems, although it will leave them unowned by any package so anyone querying them will be confused.
Comment 6 Petteri R├Ąty (RETIRED) gentoo-dev 2006-02-25 15:08:46 UTC
This could be mentioned in http://www.gentoo.org/proj/en/desktop/x/x11/modular-x-howto.xml to make it easier to migrate to modular X by deleting these files before starting emerge xorg-x11.
Comment 7 foser (RETIRED) gentoo-dev 2006-02-26 05:50:29 UTC
2 different font ebuilds shouldn't be installing the same /usr/share/fonts/ dir, at least thats an assumption we made with the fonts eclass. Can that be fixed ?
Comment 8 Donnie Berkholz (RETIRED) gentoo-dev 2006-02-26 11:08:39 UTC
(In reply to comment #7)
> 2 different font ebuilds shouldn't be installing the same /usr/share/fonts/
> dir, at least thats an assumption we made with the fonts eclass. Can that be
> fixed ?

No, because we're installing to the same locations as the monolith did, so e.g. multiple packages install to 100dpi/ , multiple others to misc/ , etc. We need to do this to avoid breaking configurations and assumptions made by every X config tool in existence.

The answer in this case, I think, will be not providing fonts.* files at all in all cases where they can be autogenerated (non-CID, non-Speedo). This means they'll essentially be orphaned files, but the x-modular eclass has a function to take care of them if they're left over in an empty directory.
Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2006-03-21 20:33:09 UTC
Fixed a couple of days ago.