Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 102500

Summary: x11-plugins/gaim-encryption building against mozilla or mozilla-firefox
Product: Gentoo Linux Reporter: Gergan Penkov <gpp666_999>
Component: New packagesAssignee: Gentoo net-im Herd <net-im>
Status: RESOLVED WONTFIX    
Severity: normal Keywords: Inclusion
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 100597    
Bug Blocks:    
Attachments: gaim-encryption-2.38-r1.ebuild

Description Gergan Penkov 2005-08-14 08:12:13 UTC
It is essentially the same bug as #102487, the problem is that gaim-encryption
link at compile-time to nss/nspr libraries, but in case mozilla/mozilla-firefox
are installed (which is probably the case in 90%), at run-time it will link to
the mozilla/mozilla-firefox set of libraries, depending on what comes exported
first in ld.so.conf. 
The ebuild, which I'll attach depends on bug #100597, because the installed
{mozilla|firefox}-nspr is not correct in the portage-ebuilds, and the other
pkg-configs do not add the -Wl,-R${libdir} to ensure consistent run-time linking. 
Moreover the ebuild for firefox from bug #100597 is needed for the
firefox-use-flag in order for the package to compile correctly, because it
installs the needed nss/nspr-includes.
The ebuild removes the dependancies on nss/nspr, because as said earlier, they
will not be used in most cases (but only if mozilla and firefox are not installed)
Comment 1 Gergan Penkov 2005-08-14 08:13:50 UTC
Created attachment 65936 [details]
gaim-encryption-2.38-r1.ebuild

The ebuild. It will build the plugin by default against mozilla, and against 
firefox, if the firefox-use flag is used.
Comment 2 Gergan Penkov 2005-08-15 17:20:30 UTC
Changed the name, as the ebuilds from bug #100597 are already in portage, and
the consistency of the run-time linking is not a problem anymore. It simply adds
the possibility to build against firefox.
Comment 3 Don Seiler (RETIRED) gentoo-dev 2005-08-18 10:39:22 UTC
You neglected to allow for the standalone nspr package, so you wouldn't need
either mozilla or mozilla-firefox.  I would wrap the whole firefox/!firefox
check in a mozilla USE flag check as well.  I'll talk things over with other
devs on the firefox USE flag.
Comment 4 Gergan Penkov 2005-08-18 10:50:03 UTC
(In reply to comment #3)
> You neglected to allow for the standalone nspr package, so you wouldn't need
> either mozilla or mozilla-firefox.  I would wrap the whole firefox/!firefox
> check in a mozilla USE flag check as well.  I'll talk things over with other
> devs on the firefox USE flag.

Yes, I know but you could not guarantee the linking if you use the nss/nspr
packages, there are already bugs about this and I think the resolution is not so
trivial, because nss/nspr do not provide pkg-config files, so the makefile would
have to be patched, the nss/nspr should also be patched. The breakage would
occur on installing mozilla or mozilla-firefox after installing this with
nss/nspr, because of possible incopatible versions.
Comment 5 Jory A. Pratt 2006-03-29 10:52:55 UTC
Everything in the tree is being moved to build against system nss/nspr mozilla will be removed from tree as soon as a seamonkey is marked stable, which is a bit out still.