Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 101136

Summary: www-client/mozilla-firefox-1.0.6-r3 segfaults
Product: Gentoo Linux Reporter: Andrej Kacian (RETIRED) <ticho>
Component: New packagesAssignee: Mozilla Gentoo Team <mozilla>
Severity: normal CC: caluml
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Andrej Kacian (RETIRED) gentoo-dev 2005-08-02 13:57:21 UTC
While browsing bugzilla (I think I was scrolling down at the moment), firefox 
suddenly crashed, and won't start again, segfaulting:

$ firefox
No running windows found

(firefox-bin:20567): Gdk-WARNING **: gdk_property_get(): length value has 
wrapped in calculation (did you pass G_MAXLONG?)
/usr/libexec/mozilla-launcher: line 119: 20567 Segmentation fault      "$mozbin" 
firefox-bin exited with non-zero status (139)

Removing entire ~/.mozilla didn't help, and this also happens under other users.

This has happened to me a week ago, but after a week of my absence at the 
computer, it worked when I came back yesterday. And now it happened again.
Comment 1 Jeremy Day 2005-09-16 17:51:05 UTC
I get almost the exact same thing only I get it on line 113 of mozilla-launcher

/usr/libexec/mozilla-launcher: line 113:  9314 Segmentation fault        "$mozbin"
Comment 2 Calum 2005-11-04 16:51:06 UTC
I don't know if it's the same, but I get a crash with 1.0.7 when I visit Every time. I've tried disabling Javascript, and removing flash,
and java plugins, but it still happens.
Also happens on
Comment 3 Calum 2005-11-04 16:59:25 UTC
This is what I get if I run it from the command line:

$ firefox
/usr/lib64/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a
running server.
No running windows found
** This is where I go to the site **
/usr/libexec/mozilla-launcher: line 116: 12744 Segmentation fault      "$mozbin"
firefox-bin exited with non-zero status (139)
Comment 4 Andrej Kacian (RETIRED) gentoo-dev 2006-04-08 06:46:38 UTC
This is no longer an issue (and hasn't been for quite some time) for me. Anyone else?
Comment 5 Stuart Longland (RETIRED) gentoo-dev 2006-07-30 06:35:40 UTC
Is this still an issue for people?  For those still having trouble, have you tried the latest releases of Firefox? (either 1.0.7-r4 or

For now, I'll mark it RESOLVED::TEST-REQUEST.  If the issue still exists, please re-open the bug and provide debugging output and `emerge --info` output.

Stuart Longland