Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 101016

Summary: intltool does not build
Product: Gentoo Linux Reporter: Balint Dobai-Pataky <dpblnt>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Balint Dobai-Pataky 2005-08-01 12:03:49 UTC
intltool-0.33 fails checking for XML::Parser, wich is allready installed.

>>> md5 files   ;-) intltool-0.33.ebuild
>>> md5 files   ;-) intltool-0.31.2.ebuild
>>> md5 files   ;-) intltool-0.32.1.ebuild
>>> md5 files   ;-) files/digest-intltool-0.31.2
>>> md5 files   ;-) files/digest-intltool-0.32.1
>>> md5 files   ;-) files/digest-intltool-0.33
>>> md5 src_uri ;-) intltool-0.33.tar.bz2
>>> Unpacking source...
>>> Unpacking intltool-0.33.tar.bz2 to /var/tmp/portage/intltool-0.33/work
>>> Source unpacked.
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is
required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/intltool-0.33/work/intltool-0.33/config.log

!!! ERROR: dev-util/intltool-0.33 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.



*  dev-perl/XML-Parser
      Latest version available: 2.34
      Latest version installed: 2.34
      Size of downloaded files: 224 kB
      Homepage:    http://search.cpan.org/~msergeant/XML-Parser-2.34/
      Description: A Perl extension interface to James Clark's XML parser, expat
      License:     Artistic



Reproducible: Always
Steps to Reproduce:





emerge --info
Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.5-r0, 2.6.12-gentoo-r4 i686)
=================================================================
System uname: 2.6.12-gentoo-r4 i686 Mobile Intel(R) Pentium(R) 4     CPU 2.66GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://gw/gentoo-portage"
USE="x86 X acpi alsa apache2 apm avi bitmap-fonts cdr crypt cups divx4linux dvd
dvdr emboss encode foomaticdb fortran fpu gd gif gmail gphoto2 gpm gtk gtk2 hal
imagemagick imap imlib ithreads jabber jpeg kqemu libg++ libwww mad mikmod mime
mmx motif mozmail mp3 mpeg mtrr ncurses nls ogg oggvorbis opengl oss pam perl
png python quicktime readline sdl softmmu sse sse2 ssl tcpd tiff truetype
truetype-fonts type1-fonts usb vorbis win32codecs xml2 xmms xv xvid zlib
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Comment 1 PaweĊ‚ Hajdan, Jr. (RETIRED) gentoo-dev 2005-08-01 12:07:42 UTC
Try running perl-cleaner. If that solves the problem, please mark as a duplicate
of bug 41124.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-08-01 13:13:27 UTC
Please, search for duplicates before filing a new bug. Thanks.

*** This bug has been marked as a duplicate of 41124 ***