Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 10

Summary: Evolution-mail segfaults
Product: Gentoo Linux Reporter: Grant Goodyear (RETIRED) <g2boojum>
Component: [OLD] GNOMEAssignee: Martin Schlemmer (RETIRED) <azarah>
Status: RESOLVED FIXED    
Severity: minor CC: hallski, hoffman, nic_spam
Priority: High    
Version: 1.0 RC6 r14   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Grant Goodyear (RETIRED) gentoo-dev 2002-01-04 09:19:09 UTC
For some reason evolution-mail segfaults.  Specifically, I see evolution 
segfault when I click on mail and then the mail-settings option.
Comment 1 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-04 11:06:54 UTC
*** Bug 11 has been marked as a duplicate of this bug. ***
Comment 2 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-04 14:57:53 UTC
test
Comment 3 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-06 19:28:48 UTC
Ok, have a way of going around the issue (I think).

The problem seems to occur if the mailclient crashes before you close the
program the first time the configure-database gets corrupted. 

If you directly after Evolution starts for the first time exits cleanly it seems
to be working as it should after that. Can this be confirmed somewhere else?

Comment 4 Grant Goodyear (RETIRED) gentoo-dev 2002-01-06 20:45:26 UTC
The shutdown-just-after-starting-the-first-time solution seems to work
just fine.  Yayyyy!!!  Changing severity to minor, now that we have a 
work-around.
Comment 5 Daniel Robbins (RETIRED) gentoo-dev 2002-01-06 22:17:53 UTC
I had this problem and had to login to my IMAP server first before opening mail
settings.  I'm marking this as fixed since I think it's more of an evolution
issue than anything we're doing wrong.
Comment 6 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-06 23:48:45 UTC
Please don't do this. I am assigned to the bug and I haven't marked it as being
resolved since I want to look in to the issue. No other distributions has this
problem. I wan't to make sure it's not due to our default -O3 CFLAGS.
Comment 7 Grant Goodyear (RETIRED) gentoo-dev 2002-01-07 13:00:08 UTC
Hmmm.  I often get a segfault when trying to print from an email, but it doesn't
happen all of the time.  Worse, I don't see any pattern of when it happens.
Comment 8 JP Sartre 2002-01-19 11:14:09 UTC
Well, I don't know about you guys, but I segfault everytime I try to apply a new
filter. Just installed gentoo, so maybe I'm missing something? I can read and
delete email fine, just can't add filters. Not sure if this is related or should
be a new bug?

JP
Comment 9 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-19 12:19:36 UTC
it's probably not related.
Comment 10 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-26 11:00:41 UTC
The filter crash is fixed in 1.0.1-r2.
Comment 11 Grant Goodyear (RETIRED) gentoo-dev 2002-02-07 10:08:37 UTC
*** Bug 563 has been marked as a duplicate of this bug. ***
Comment 12 Grant Goodyear (RETIRED) gentoo-dev 2002-02-08 15:27:11 UTC
*** Bug 602 has been marked as a duplicate of this bug. ***
Comment 13 Nathan Quinlan 2002-05-28 07:55:42 UTC
First time installer of Gentoo, I got the iso image last week and finished 
installing everything yesturday.  This Evolution bug still appears to exist.  
Emerge installed Evolution 1.0.5 and since I didn't exit after doing the wizard 
the evolution-mail process keeps segfaulting.
After removing ~/evolution and following the work around it no longer segfaults 
but this bug still happens.

Should be re-opened.