Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
View | Details | Raw Unified | Return to bug 613850 | Differences between
and this patch

Collapse All | Expand All

(-)file_not_specified_in_diff (-6 / +14 lines)
Line  Link Here
0
-- gcalcli-3.3.2.ebuild
0
++ gcalcli-3.4.0.ebuild
Lines 1-9 Link Here
1
# Copyright 1999-2015 Gentoo Foundation
1
# Copyright 1999-2017 Gentoo Foundation
2
# Distributed under the terms of the GNU General Public License v2
2
# Distributed under the terms of the GNU General Public License v2
3
3
4
EAPI=5
4
EAPI=5
5
# google-api-python-client only supports these
5
# python-gflags doesn't support python3
6
PYTHON_COMPAT=( python2_7 pypy )
6
# parsedatetime doesn't support pypy
7
PYTHON_COMPAT=( python2_7 )
7
8
8
inherit python-r1
9
inherit python-r1
9
10
Lines 18-27 Link Here
18
19
19
DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
20
DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
20
		 dev-python/google-api-python-client[${PYTHON_USEDEP}]
21
		 dev-python/google-api-python-client[${PYTHON_USEDEP}]
21
		 dev-python/gdata[${PYTHON_USEDEP}]
22
		 dev-python/python-gflags[${PYTHON_USEDEP}]
22
		 dev-python/vobject[${PYTHON_USEDEP}]"
23
		 dev-python/httplib2[${PYTHON_USEDEP}]
24
		 dev-python/oauth2client[${PYTHON_USEDEP}]
25
		 dev-python/vobject[${PYTHON_USEDEP}]
26
		 dev-python/parsedatetime[${PYTHON_USEDEP}]"
23
RDEPEND="${DEPEND}"
27
RDEPEND="${DEPEND}"
24
28
29
src_prepare() {
30
	epatch "${FILESDIR}/gcalcli-oauth2client.patch"
31
}
32
25
src_install() {
33
src_install() {
26
	dodoc -r ChangeLog README.md docs
34
	dodoc -r ChangeLog README.md docs
27
	python_foreach_impl python_doscript ${PN}
35
	python_foreach_impl python_doscript ${PN}

Return to bug 613850