Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
View | Details | Raw Unified | Return to bug 212376
Collapse All | Expand All

(-)/usr/portage/net-firewall/fwbuilder/fwbuilder-2.1.14.ebuild (-9 lines)
Lines 15-31 Link Here
15
15
16
DEPEND="~net-libs/libfwbuilder-${PV}
16
DEPEND="~net-libs/libfwbuilder-${PV}
17
	nls? ( >=sys-devel/gettext-0.11.4 )
17
	nls? ( >=sys-devel/gettext-0.11.4 )
18
	~dev-java/antlr-2.7.7
19
	>=dev-libs/libxslt-1.0.7"
18
	>=dev-libs/libxslt-1.0.7"
20
19
21
pkg_setup() {
22
	if built_with_use dev-java/antlr nocxx; then
23
		eerror "dev-java/antlr can't be compiled with nocxx."
24
		eerror "recompile it without that use flag set."
25
		die "Need dev-java/antlr compiled without the nocxx use flag set"
26
	fi
27
}
28
29
src_compile() {
20
src_compile() {
30
	# we'll use our eqmake instead of bundled script to process qmake files
21
	# we'll use our eqmake instead of bundled script to process qmake files
31
	sed -i -e 's:^. ./runqmake.sh$:echo:' configure \
22
	sed -i -e 's:^. ./runqmake.sh$:echo:' configure \

Return to bug 212376